classification
Title: xmlrpclib closes connection after each call
Type: enhancement Stage:
Components: Library (Lib) Versions: Python 2.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: effbot Nosy List: effbot, erno, gpolo, haypo
Priority: normal Keywords:

Created on 2008-02-12 11:04 by erno, last changed 2009-09-14 10:44 by haypo. This issue is now closed.

Files
File name Uploaded Description Edit
transport.py erno, 2008-02-12 11:04
Messages (3)
msg62309 - (view) Author: Erno Kuusela (erno) Date: 2008-02-12 11:04
xmlrpclib is using the old HTTP and HTTPS classes from httplib which are
to quote the docstring, "Compatibility classes with httplib.py from 1.5."
and force the use of HTTP 1.0. This prevents connection reuse and
pipelining.

Attacked is some code we are using as a workaround.

Is the xmlrpclib in the standard library required to keep compatibility
with old python versions?
msg64330 - (view) Author: Guilherme Polo (gpolo) * (Python committer) Date: 2008-03-22 15:49
There is already a patch for using HTTP/1.1 in xmlrpclib:
http://bugs.python.org/issue1767370

There is also another open issue related to this, so the best to do here
is some "merging" of issues and patches and leave just one of them open.
msg92599 - (view) Author: STINNER Victor (haypo) * (Python committer) Date: 2009-09-14 10:44
I think that xmlrpclib is already fixed in Python trunk. See #6267. I consider
this issue as a duplicate of #6267.
History
Date User Action Args
2009-09-14 10:44:32hayposetstatus: open -> closed

nosy: + haypo
messages: + msg92599

resolution: duplicate
2008-03-22 15:49:56gpolosetnosy: + gpolo
messages: + msg64330
2008-03-18 19:42:51jafosetpriority: normal
assignee: effbot
type: enhancement
nosy: + effbot
2008-02-12 11:04:08ernocreate