classification
Title: Add example to tutorial namespace doc, section 9.2
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: BreamoreBoy, berker.peksag, docs@python, krichter
Priority: normal Keywords:

Created on 2014-02-19 08:27 by krichter, last changed 2016-09-08 18:14 by berker.peksag. This issue is now closed.

Messages (3)
msg211607 - (view) Author: Karl Richter (krichter) Date: 2014-02-19 08:27
The explanation of namespaces in section 9.2 in documentation (http://docs.python.org/3/tutorial/classes.html#python-scopes-and-namespaces) is just so complicated without (at least one tiny) example. The example would ease the comprehension of the section by a high factor.
msg236619 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2015-02-25 20:52
What is wrong with the example given here https://docs.python.org/3/tutorial/classes.html#scopes-and-namespaces-example ?
msg266795 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-06-01 02:15
Thanks for the report, Karl. Could you give more details about what's missing? The section gives some examples of namespaces:

    [...] the set of built-in names (containing functions such as abs(), and built-in exception names); the global names in a module; and the local names in a function invocation.

I'm not sure if it's worth to convert them to code examples.
History
Date User Action Args
2016-09-08 18:14:21berker.peksagsetstatus: pending -> closed
resolution: not a bug
stage: resolved
2016-06-01 02:16:21berker.peksagsetstatus: open -> pending
nosy: + berker.peksag
messages: + msg266795

2015-02-25 20:52:40BreamoreBoysetnosy: + BreamoreBoy
messages: + msg236619
2014-02-21 22:29:07terry.reedysettitle: [doc] Ease comprehension of section 9.2 of docs for Python 2 and 3 with example -> Add example to tutorial namespace doc, section 9.2
versions: + Python 2.7, Python 3.4
2014-02-19 08:27:32krichtercreate