classification
Title: Bundle pip 1.5.3 in Python 3.4rc2
Type: behavior Stage:
Components: Versions: Python 3.4
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: dstufft Nosy List: Marcus.Smith, asmodai, dstufft, larry, ncoghlan, paul.moore, r.david.murray
Priority: release blocker Keywords:

Created on 2014-02-09 04:20 by ncoghlan, last changed 2014-02-23 07:07 by larry. This issue is now closed.

Messages (16)
msg210717 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2014-02-09 04:20
Larry, we currently have 0.15.2 bundled for 3.4rc1. This is the latest release of pip: http://www.pip-installer.org/en/latest/news.html#changelog

However, there are a few additional fixes that have been merged to the pip 1.5.X maintenance branch that could be included in a 0.15.3 release:

- the workaround to resolve issue 20053 on Windows
- a number of fixes related to wheel downloads
- ensuring hash fragments in URLs are checked properly

It would be good to get those resolved prior to the final 3.4 release.
msg210720 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2014-02-09 04:56
Donald also pointed out that we want the fix to make pip complain if it is passed a wheel 2.0+ file (it's currently missing the version number warnings/errors that are called for in PEP 427). That isn't merged yet upstream, but will be part of 0.15.3.

I interpreted Larry's comments on IRC as in-principle approval, so passing this to Donald to resolve (3.4rc2 is scheduled for February 23rd).
msg210721 - (view) Author: Donald Stufft (dstufft) * (Python committer) Date: 2014-02-09 04:57
Just t be clear, it's 1.5.3 not 0.15.3.
msg210722 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2014-02-09 04:57
Oops - 0.15.3 was the version of Beaker we just released, so my brain keeps confusing the two numbers :)
msg210756 - (view) Author: Jeroen Ruigrok van der Werven (asmodai) * (Python committer) Date: 2014-02-09 13:06
Nick et al,

currently trying b3 and using the bundled pip (1.5.2) to update the bundled setuptools from 2.1 to 2.2 on Windows 7 and I get the following. Any idea if this is still an issue with the newer versions (and thus might be relevant to this case)?

F:\Python34>Scripts\pip3.4.exe install -U setuptools
Downloading/unpacking setuptools from https://pypi.python.org/packages/3.4/s/setuptools/setuptools-2.2-py2.py3-none-any.whl#md5=3b7d84f496aed8c07b91efba4aa197a4

Cleaning up...
Exception:
Traceback (most recent call last):
  File "F:\Python34\lib\site-packages\pip\basecommand.py", line 122, in main
    status = self.run(options, args)
  File "F:\Python34\lib\site-packages\pip\commands\install.py", line 274, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "F:\Python34\lib\site-packages\pip\req.py", line 1206, in prepare_files
    for subreq in dist.requires(req_to_install.extras):
  File "F:\Python34\lib\site-packages\pip\_vendor\pkg_resources.py", line 2232, in requires
    dm = self._dep_map
  File "F:\Python34\lib\site-packages\pip\_vendor\pkg_resources.py", line 2423, in _dep_map
    self.__dep_map = self._compute_dependencies()
  File "F:\Python34\lib\site-packages\pip\_vendor\pkg_resources.py", line 2445, in _compute_dependencies
    for req in self._parsed_pkg_info.get_all('Requires-Dist') or []:
  File "F:\Python34\lib\site-packages\pip\_vendor\pkg_resources.py", line 2415, in _parsed_pkg_info
    self._pkg_info = Parser().parsestr(self.get_metadata(self.PKG_INFO))
  File "F:\Python34\lib\email\parser.py", line 70, in parsestr
    return self.parse(StringIO(text), headersonly=headersonly)
  File "F:\Python34\lib\email\parser.py", line 60, in parse
    return feedparser.close()
  File "F:\Python34\lib\email\feedparser.py", line 170, in close
    self._call_parse()
  File "F:\Python34\lib\email\feedparser.py", line 163, in _call_parse
    self._parse()
  File "F:\Python34\lib\email\feedparser.py", line 449, in _parsegen
    self._cur.set_payload(EMPTYSTRING.join(lines))
  File "F:\Python34\lib\email\message.py", line 311, in set_payload
    " payload") from None
TypeError: charset argument must be specified when non-ASCII characters are used in the payload

Storing debug log for failure in C:\Users\asmodai\pip\pip.log
msg210785 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2014-02-09 20:27
I believe that may be an actual bug in the 3.4b3 email module (especially
if pip 1.5.2 behaves itself in 3.3). If you can reproduce the error with
the default branch (or rc1 when it's available), please file a new issue
(with me, Larry and R. David Murray on the nosy list). If it doesn't happen
with rc1,then I would assume it was caused by one of the 3.4 email issues
that David fixed recently.
msg210792 - (view) Author: Jeroen Ruigrok van der Werven (asmodai) * (Python committer) Date: 2014-02-09 22:58
Yes, looks like it is just the email module:

F:\Python33>Scripts\pip3.3.exe install -U setuptools
Downloading/unpacking setuptools from https://pypi.python.org/packages/3.4/s/setuptools/setuptools-2.2-py2.py3-none-any.whl#md5=3b7d84f496aed8c07b91efba4aa197a4

Installing collected packages: setuptools
  Found existing installation: setuptools 2.1
    Uninstalling setuptools:
      Successfully uninstalled setuptools
Successfully installed setuptools
Cleaning up...

I'll check rc1 when it's released by Larry and file as needed. Thanks for verifying.
msg210793 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-02-09 23:27
Yes, that issue was fixed on Friday.  It is *possible* the fix still has a problem though, since the code in question is still different from that in 3.3.3.
msg211314 - (view) Author: Jeroen Ruigrok van der Werven (asmodai) * (Python committer) Date: 2014-02-16 12:27
Just to confirm that I, indeed, did not run into problems any more with RC1 trying to upgrade setuptools.
msg211318 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2014-02-16 14:07
Donald, since you haven't been through an RC period before - just a reminder that Larry is going to need time to cherry pick the update into the release clone before rc2 on the 23rd.
msg211333 - (view) Author: Donald Stufft (dstufft) * (Python committer) Date: 2014-02-16 18:06
Yea, I'll get it done. Was planning on doing it this weekend but I had a medical issue. I'll see about getting all the things get done asap.
msg211343 - (view) Author: Donald Stufft (dstufft) * (Python committer) Date: 2014-02-16 19:13
I put out the email that I'll be rolling 1.5.3 tues/weds of next week (so 18th or 19th). Hopefully that's a reasonable time schedule.
msg211447 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-17 21:37
When you land this fix, please create the separate "3.4 cherry-pick" issue.  Those issues are helping me a lot with keeping track of everything.
msg211683 - (view) Author: Donald Stufft (dstufft) * (Python committer) Date: 2014-02-20 02:13
Just a FYI I'm going to be cutting this release sometime in the next 6-12 hours and I'll commit it to the CPython repository and make the cherry-pick request.
msg211788 - (view) Author: Donald Stufft (dstufft) * (Python committer) Date: 2014-02-21 01:57
I created issue20713
msg211981 - (view) Author: Larry Hastings (larry) * (Python committer) Date: 2014-02-23 07:07
My understanding is this is now done.  If it isn't please reopen.
History
Date User Action Args
2014-02-23 07:07:37larrysetstatus: open -> closed
resolution: fixed
messages: + msg211981
2014-02-21 01:57:30dstufftsetmessages: + msg211788
2014-02-20 02:13:32dstufftsetmessages: + msg211683
2014-02-17 21:37:12larrysetmessages: + msg211447
2014-02-16 19:13:27dstufftsetmessages: + msg211343
2014-02-16 18:06:56dstufftsetmessages: + msg211333
2014-02-16 14:07:22ncoghlansetmessages: + msg211318
2014-02-16 12:27:27asmodaisetmessages: + msg211314
2014-02-15 22:32:25ncoghlansetpriority: deferred blocker -> release blocker
2014-02-09 23:27:28r.david.murraysetnosy: + r.david.murray
messages: + msg210793
2014-02-09 22:58:13asmodaisetmessages: + msg210792
2014-02-09 20:27:48ncoghlansetmessages: + msg210785
2014-02-09 13:06:42asmodaisetnosy: + asmodai
messages: + msg210756
2014-02-09 04:57:54ncoghlansetmessages: + msg210722
title: Bundle pip 0.15.3 in Python 3.4rc2 -> Bundle pip 1.5.3 in Python 3.4rc2
2014-02-09 04:57:04dstufftsetmessages: + msg210721
2014-02-09 04:56:09ncoghlansetassignee: larry -> dstufft
messages: + msg210720
2014-02-09 04:24:40ncoghlansetnosy: + Marcus.Smith
2014-02-09 04:22:14ncoghlanlinkissue20053 dependencies
2014-02-09 04:20:15ncoghlancreate