classification
Title: sqlite3 returns result set with doubled first entry
Type: behavior Stage: resolved
Components: Extension Modules Versions: Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: sqlite3.InterfaceError after commit
View: 10513
Assigned To: ghaering Nosy List: Claudiu.Popa, berker.peksag, ghaering, jwezel, r.david.murray
Priority: high Keywords:

Created on 2014-02-08 12:43 by jwezel, last changed 2016-08-26 20:22 by berker.peksag. This issue is now closed.

Files
File name Uploaded Description Edit
t.py jwezel, 2014-02-08 12:43 Script reproducing the bug
t.py r.david.murray, 2014-02-08 14:52
Messages (4)
msg210622 - (view) Author: Johnny Wezel (jwezel) Date: 2014-02-08 12:43
I could isolate a bug where sqlite3 returns a result set from a select where the first entry occurs twice.

>>> sys.version_info  
sys.version_info(major=2, minor=7, micro=5, releaselevel='final', serial=0)
>>> import sqlite3
>>> sqlite3.version_info
(2, 6, 0)

$ uname -a
Linux 3.10.25-gentoo #1 SMP PREEMPT Wed Jan 29 18:05:47 CET 2014 x86_64 Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz GenuineIntel GNU/Linux
msg210655 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-02-08 14:52
Here is an even more cut down example.  Note that removing the commit avoids the problem.
msg221680 - (view) Author: PCManticore (Claudiu.Popa) * (Python triager) Date: 2014-06-27 07:09
issue10513 has a patch that fixes this problem as well.
msg273724 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2016-08-26 20:22
This is basically a duplicate of issue 10513.
History
Date User Action Args
2016-08-26 20:22:05berker.peksagsetstatus: open -> closed

superseder: sqlite3.InterfaceError after commit

nosy: + berker.peksag
messages: + msg273724
resolution: duplicate
stage: resolved
2015-01-11 01:59:45ghaeringsetassignee: ghaering

nosy: + ghaering
2014-06-27 07:39:30rhettingersetpriority: normal -> high
2014-06-27 07:09:05Claudiu.Popasetnosy: + Claudiu.Popa
messages: + msg221680
2014-02-08 14:52:30r.david.murraysetfiles: + t.py
versions: + Python 3.3, Python 3.4
nosy: + r.david.murray

messages: + msg210655
2014-02-08 12:43:08jwezelcreate