classification
Title: ``clinic.py --converters`` raises an exception
Type: behavior Stage: resolved
Components: Build Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Argument Clinic rollup patch, 2014/01/31
View: 20456
Assigned To: larry Nosy List: brett.cannon, larry, zach.ware
Priority: release blocker Keywords:

Created on 2014-01-31 16:17 by brett.cannon, last changed 2014-01-31 16:26 by zach.ware. This issue is now closed.

Messages (2)
msg209802 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2014-01-31 16:17
> ./python.exe Tools/clinic/clinic.py --converters              ~/Repositories/cpython/default

Legacy converters:
Traceback (most recent call last):
  File "Tools/clinic/clinic.py", line 4045, in <module>
    sys.exit(main(sys.argv[1:]))
  File "Tools/clinic/clinic.py", line 3977, in main
    print('    ' + ' '.join(c for c in legacy if c[0].isupper()))
  File "Tools/clinic/clinic.py", line 3977, in <genexpr>
    print('    ' + ' '.join(c for c in legacy if c[0].isupper()))
IndexError: string index out of range
msg209805 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2014-01-31 16:26
This is a duplicate of (part of) #20456; adding you there, Brett.
History
Date User Action Args
2014-01-31 16:26:22zach.waresetstatus: open -> closed

superseder: Argument Clinic rollup patch, 2014/01/31

nosy: + zach.ware
messages: + msg209805
resolution: duplicate
stage: needs patch -> resolved
2014-01-31 16:17:38brett.cannoncreate