classification
Title: Duplicate namespace package portions (but not on Windows)
Type: behavior Stage: resolved
Components: Versions: Python 3.4, Python 3.5
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: BreamoreBoy, Caio Ariede, brett.cannon, carljm, eric.smith, eric.snow
Priority: normal Keywords:

Created on 2013-11-01 06:05 by eric.snow, last changed 2017-03-07 19:22 by serhiy.storchaka. This issue is now closed.

Messages (6)
msg201880 - (view) Author: Eric Snow (eric.snow) * (Python committer) Date: 2013-11-01 06:05
In changeset 88c3a1a3c2ff you'll find in test_api.py where I threw together a __path__ to compare against the one I was getting (which had 2 identical entries) on my Ubuntu 12.04 workstation.  The XP buildbot (http://buildbot.python.org/all/builders/x86%20XP-4%203.x) took issue with that (but non-windows was fine).

I was able to work around the difference (78d36d54391c), but I find the extra namespace portions surprising.  I'd like to get to the bottom of it.  I expect it has to do with how path entries are done on Windows, or perhaps with the way support.temp_cwd() iteracts with sys.path during testing.
msg228280 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-10-02 23:46
Just a gentle reminder guys.
msg248969 - (view) Author: Carl Meyer (carljm) * Date: 2015-08-21 18:29
FWIW, this bug has bitten Django; see https://code.djangoproject.com/ticket/25246

We can easily work around it for future versions, but we have code in released versions that assumed that `__path__` wouldn't contain dupes; it causes us to raise an error in a situation that shouldn't be an error (because we need a Django "app" module to have exactly one filesystem location).
msg248977 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2015-08-21 19:53
I can't reproduce under Python 3.4.3, the 3.4 branch, 3.5 branch, or default with a plain namespace package. Can anyone come up with a test case that can reproduce this problem? Otherwise I'll assume it was a bug that got fixed in 3.4.2.
msg249030 - (view) Author: Caio Ariede (Caio Ariede) Date: 2015-08-23 23:48
I tried to reproduce it using Python 3.4.3 and 3.4.2. No luck.
msg249062 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2015-08-24 16:28
OK, if someone finds a way to reproduce the bug in the next week then we will keep this open as active, else I'm closing it as out-of-date.
History
Date User Action Args
2017-03-07 19:22:27serhiy.storchakasetstatus: pending -> closed
resolution: out of date
stage: test needed -> resolved
2015-08-24 16:28:40brett.cannonsetstatus: open -> pending

messages: + msg249062
2015-08-23 23:48:46Caio Ariedesetstatus: pending -> open
nosy: + Caio Ariede
messages: + msg249030

2015-08-21 19:53:42brett.cannonsetstatus: open -> pending

messages: + msg248977
2015-08-21 18:29:44carljmsetnosy: + carljm
messages: + msg248969
2014-10-02 23:46:08BreamoreBoysetnosy: + BreamoreBoy

messages: + msg228280
versions: + Python 3.5
2013-11-01 06:05:32eric.snowcreate