classification
Title: IDLE wont open
Type: performance Stage: resolved
Components: IDLE Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: MrE.Merry, oldschoolburke, terry.reedy
Priority: normal Keywords:

Created on 2013-10-23 17:35 by MrE.Merry, last changed 2014-10-03 02:45 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
Error.gif MrE.Merry, 2013-10-23 17:35 Image of error message.
Messages (4)
msg201051 - (view) Author: MrE Merry (MrE.Merry) Date: 2013-10-23 17:35
Python IDLE won't open - just get firewall error message, yet no firewalls are present.  Tried both on school laptop (I'm a teacher) and pupil work station (logged on as myself).  Students are able to open IDLE without issues.
msg201106 - (view) Author: Arjit Srivastava (oldschoolburke) Date: 2013-10-24 09:31
Hi MrE.Merry,


There may be a file clashing with the normal python files. 

I guess, you could take a look into your Python directory, and see if you have .py file which has a name of another python module/keyword, causing it to conflict with the normal module in python. Remove that/those files, or move that/those files to some other directory, and see if IDLE starts working for you again. I would suggest you look in your main python directory and see if there are any .py files that you could move to different places.

Or, simply, you can cut all files with .py extension, paste them in a place different from the os path. Run the IDLE again.
msg201305 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-10-26 00:25
(Usage questions are generally better directed at python-list, but I will try to answer here first.)

It is actually a 'connection not made' error, with a Firewall being only one possible cause for the non-connection. Questions:
What OS? Windows? Mac? or ???
What exact Python version was installed? 3.3.2? or something else?

How was it installed? For source or binary installer? Installed for one user? or all? Are you saying that on one machine a student can use it (logged in as student) but you cannot (logged in as teacher)?
msg228297 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-10-03 02:45
Duplicate of other, similar reports; no new information.
History
Date User Action Args
2014-10-03 02:45:11terry.reedysetstatus: open -> closed
versions: + Python 2.7, - Python 3.3
messages: + msg228297

resolution: duplicate
stage: resolved
2013-10-26 00:25:46terry.reedysetnosy: + terry.reedy
messages: + msg201305
2013-10-24 09:31:44oldschoolburkesetnosy: + oldschoolburke
messages: + msg201106
2013-10-23 17:35:43MrE.Merrycreate