classification
Title: test_posix failure on OS X snow leopord buildbot
Type: Stage: resolved
Components: macOS, Tests Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: ned.deily, r.david.murray, ronaldoussoren
Priority: normal Keywords: buildbot

Created on 2013-09-20 22:32 by r.david.murray, last changed 2013-09-21 01:42 by r.david.murray. This issue is now closed.

Messages (3)
msg198177 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-09-20 22:32
The new OS X buildbot is failing in test_posix:

======================================================================
FAIL: test_getgroups (test.test_posix.PosixTester)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/buildbot/buildarea/3.x.murray-snowleopard/build/Lib/test/test_posix.py", line 734, in test_getgroups
    set(posix.getgroups() + [posix.getegid()]))
AssertionError: Items in the second set but not the first:
1

I can't reproduce this at the command line, so it probably has something to do with the fact that buildbot is running in daemon mode.
msg198179 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2013-09-21 00:14
From irc, I believe RDM has changed the buildbot to run under a group that the user is a member of ("staff") and so I think this issue can be closed.  David?
msg198180 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-09-21 01:41
Yes, the problem turned out to be that the buildslave process was running under group 'daemon' (1), but the buildbot userid that it was running under was not part of that group.  So I changed the run group to 'staff', which buildbot is a member of, and the test passed.  So I consider this a bug in the buildbot setup rather than a bug in the test.
History
Date User Action Args
2013-09-21 01:42:11r.david.murraysetresolution: out of date -> not a bug
2013-09-21 01:41:53r.david.murraysetstatus: pending -> closed

messages: + msg198180
2013-09-21 00:14:36ned.deilysetstatus: open -> pending
resolution: out of date
messages: + msg198179

stage: resolved
2013-09-20 22:43:40ned.deilysetnosy: + ned.deily
2013-09-20 22:35:26r.david.murraysetassignee: ronaldoussoren

components: + macOS
nosy: + ronaldoussoren
2013-09-20 22:32:24r.david.murraycreate