classification
Title: Document useful functions in ‘pydoc’ module
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Make generally useful pydoc functions public
View: 7798
Assigned To: docs@python Nosy List: berker.peksag, bignose, docs@python, martin.panter
Priority: normal Keywords:

Created on 2013-09-07 05:38 by bignose, last changed 2016-04-29 17:04 by berker.peksag. This issue is now closed.

Messages (2)
msg197138 - (view) Author: Ben Finney (bignose) Date: 2013-09-07 05:38
The library documentation for ‘pydoc’ expects that the ‘pydoc’ module will only ever be run as a command-line program. This ignores the general usefulness of several of the functions in that module when imported from the library.

The documentation should describe at least the following functions:

* pydoc.getdoc

* pydoc.synopsis

* pydoc.splitdoc

The following would be useful also:

* pydoc.classname

* pydoc.cram

* pydoc.allmethods
msg197139 - (view) Author: Berker Peksag (berker.peksag) * (Python committer) Date: 2013-09-07 05:58
Looks like duplicate of issue 7798.

> * pydoc.getdoc

http://docs.python.org/3.4/library/inspect.html#inspect.getdoc

> * pydoc.splitdoc

See issue 12916 for inspect.splitdoc.

> * pydoc.cram

This was rejected in issue 12914.

> * pydoc.allmethods

This was rejected in issue 12917.
History
Date User Action Args
2016-04-29 17:04:44berker.peksagsetstatus: open -> closed
superseder: Make generally useful pydoc functions public
resolution: duplicate
stage: resolved
2014-02-10 22:53:32martin.pantersetnosy: + martin.panter
2013-09-07 05:58:24berker.peksagsetnosy: + berker.peksag

messages: + msg197139
versions: - Python 2.6, Python 3.1, Python 3.2, Python 3.5
2013-09-07 05:38:56bignosecreate