classification
Title: Prepend Is Not A Word
Type: Stage:
Components: Installation Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: benjamin.peterson, gwideman, opticyclic
Priority: normal Keywords:

Created on 2013-09-05 21:11 by opticyclic, last changed 2013-09-05 21:38 by gwideman. This issue is now closed.

Messages (3)
msg197025 - (view) Author: Johnny Boy (opticyclic) Date: 2013-09-05 21:11
If you do a custom install on Windows and click "Add python.exe to Path" the text below says "Prepend c:\Python33\ to the system Path variable"

Prepend is not a word!
The word you are looking for is Prefix.
http://encyclopedia2.thefreedictionary.com/prepend
"
Although it sounds correct, prepend is not an English word. It was created to sound like the opposite of "append," which means to add to the end. The correct English word is "prefix;"
"
msg197027 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2013-09-05 21:15
It is however a very common programming term.
msg197028 - (view) Author: Graham Wideman (gwideman) Date: 2013-09-05 21:38
"Prepend" appears in every online dictionary I consulted. For a dictionary to list it and give the usual meaning for it, pretty much demonstrates "prepend" functioning as a real word. That and its 1.3 million hits on google.

"Prepend" certainly has a commonly understood meaning, particularly in computing. 

To the extent that "prepend" has became popular as the appropriate-sounding opposite of "append", that is exactly why it _should_ be used in this context... where one might well need to discuss adding strings before or after, and be clear about the distinction.
History
Date User Action Args
2013-09-05 21:38:37gwidemansetnosy: + gwideman
messages: + msg197028
2013-09-05 21:15:10benjamin.petersonsetstatus: open -> closed

nosy: + benjamin.peterson
messages: + msg197027

resolution: not a bug
2013-09-05 21:11:25opticycliccreate