classification
Title: [distutils] - error when processing the "--formats=tar" option
Type: behavior Stage:
Components: Distutils Versions: Python 3.0, Python 3.1, Python 2.7, Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Permit to easily use distutils "--formats=tar,gztar,bztar" on all systems
View: 1886
Assigned To: tarek Nosy List: christian.heimes, giampaolo.rodola, tarek, techtonik
Priority: normal Keywords: patch

Created on 2008-01-21 20:43 by giampaolo.rodola, last changed 2009-01-26 17:26 by tarek. This issue is now closed.

Files
File name Uploaded Description Edit
issue1885.tar.removed.fix.diff techtonik, 2008-12-26 14:05 patch
1885.patch tarek, 2008-12-27 13:04
Messages (6)
msg61445 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2008-01-21 20:43
Steps to reproduce the problem:
1: Run "python setup.py sdist --formats=gztar,tar".
2. dist directory now contains "module.gztar" and "module.tar" files
as expected.
3: Run "python setup.py sdist --formats=tar,gztar".
4. dist directory now contains only "module.gztar" file.

Reason:
Since for every argument specified in "--formats" option a new .tar file
is created every time by using the UNIX tar utility, the .tar file is
removed/overwritten when creating subsequent archives.
msg61452 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2008-01-21 21:30
I provided a patch here: http://bugs.python.org/issue1886
msg61472 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2008-01-22 00:59
No need to keep two buss open.
msg78299 - (view) Author: anatoly techtonik (techtonik) Date: 2008-12-26 14:05
Please reopen this bug. issue#1886 is different it take a long time
until it is committed.

I attach patch from Giampaolo here.
msg80548 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-01-25 23:35
fixed in r68951 in trunk. 

I will propagate the change into 2.6/3.0/3.1 tomorrow.
msg80581 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-01-26 17:26
done (in r68969 for py3k branch)
History
Date User Action Args
2009-01-26 17:26:02tareksetstatus: open -> closed
messages: + msg80581
2009-01-25 23:35:28tareksetmessages: + msg80548
versions: + Python 3.0, Python 3.1, - Python 2.5
2008-12-27 13:04:45tareksetfiles: + 1885.patch
2008-12-27 13:04:35tareksetfiles: - 1885.patch
2008-12-27 11:49:59tareksetstatus: closed -> open
assignee: tarek
files: + 1885.patch
nosy: + tarek
2008-12-26 14:05:50techtoniksetfiles: + issue1885.tar.removed.fix.diff
keywords: + patch
messages: + msg78299
nosy: + techtonik
versions: + Python 2.5, Python 2.7
2008-01-22 00:59:29christian.heimessetstatus: open -> closed
versions: + Python 2.6, - Python 2.5
nosy: + christian.heimes
messages: + msg61472
priority: normal
superseder: Permit to easily use distutils "--formats=tar,gztar,bztar" on all systems
resolution: duplicate
2008-01-21 21:30:36giampaolo.rodolasetmessages: + msg61452
2008-01-21 20:43:30giampaolo.rodolacreate