classification
Title: 2.7.5-r2: Fatal Python error: Segmentation fault
Type: crash Stage: resolved
Components: Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: mmokrejs, terry.reedy, tim.peters
Priority: normal Keywords:

Created on 2013-08-26 19:47 by mmokrejs, last changed 2013-12-01 20:23 by mmokrejs. This issue is now closed.

Files
File name Uploaded Description Edit
matplotlib_crash_1676__SRR091640_shortened.txt mmokrejs, 2013-08-26 19:46 matplotlib_crash_1676__SRR091640_shortened.txt
Messages (6)
msg196239 - (view) Author: Martin Mokrejs (mmokrejs) Date: 2013-08-26 19:46
While running my app testsuite I have another one which crashed.

Fatal Python error: Segmentation fault

Current thread 0x00007fe8d3527700:
  File "/usr/lib64/python2.7/site-packages/matplotlib/transforms.py", line 2370 in get_matrix
  File "/usr/lib64/python2.7/site-packages/matplotlib/transforms.py", line 2203 in get_affine
  File "/usr/lib64/python2.7/site-packages/matplotlib/transforms.py", line 2175 in transform_affine
  File "/usr/lib64/python2.7/site-packages/matplotlib/transforms.py", line 1238 in transform
  File "/usr/lib64/python2.7/site-packages/matplotlib/transforms.py", line 1030 in get_points
  File "/usr/lib64/python2.7/site-packages/matplotlib/transforms.py", line 277 in __array__
  File "/usr/lib64/python2.7/site-packages/matplotlib/backends/backend_agg.py", line 110 in draw_path_collection
  File "/usr/lib64/python2.7/site-packages/matplotlib/collections.py", line 259 in draw
  File "/usr/lib64/python2.7/site-packages/matplotlib/artist.py", line 54 in draw_wrapper
  File "/usr/lib64/python2.7/site-packages/matplotlib/collections.py", line 695 in draw
  File "/usr/lib64/python2.7/site-packages/matplotlib/artist.py", line 54 in draw_wrapper
  File "/usr/lib64/python2.7/site-packages/matplotlib/axes.py", line 2086 in draw
  File "/usr/lib64/python2.7/site-packages/matplotlib/artist.py", line 54 in draw_wrapper
  File "/usr/lib64/python2.7/site-packages/matplotlib/figure.py", line 1006 in draw
  File "/usr/lib64/python2.7/site-packages/matplotlib/artist.py", line 54 in draw_wrapper
  File "/usr/lib64/python2.7/site-packages/matplotlib/backends/backend_agg.py", line 440 in draw
  File "/usr/lib64/python2.7/site-packages/matplotlib/backends/backend_agg.py", line 492 in print_png
  File "/usr/lib64/python2.7/site-packages/matplotlib/backend_bases.py", line 2096 in print_figure
  File "/usr/lib64/python2.7/site-packages/matplotlib/figure.py", line 1370 in savefig

  I wanted to draw 55620 dots in a scatter plot, each with a legend and its associated color. Actually only 100 color are used and multiple adjacent dots in the series have same color as necessary.


Is this a matplotlib or a python error?
msg196242 - (view) Author: Tim Peters (tim.peters) * (Python committer) Date: 2013-08-26 19:55
Impossible to know, but since everything in the traceback comes from matplotlib, the error is most likely in matplotlib.
msg196255 - (view) Author: Tim Peters (tim.peters) * (Python committer) Date: 2013-08-27 00:43
Note that the same poster is also reporting memory corruption in issue 18843.  I suggest ignoring this one unless/until the earlier bug is resolved (memory corruption can easily cause a segfault - or any other kind of error).
msg196579 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-08-30 21:27
I think this should be closed as extremely likely to be a matplotlib error.
msg196584 - (view) Author: Tim Peters (tim.peters) * (Python committer) Date: 2013-08-30 21:56
As issue 18843 has evolved, seems more likely now that it's flaky HW, but agreed in any case there's really no evidence of a Python problem here.  So closing it.  Martin, we can revisit this if there's real progress on the other issue.
msg204956 - (view) Author: Martin Mokrejs (mmokrejs) Date: 2013-12-01 20:23
The issue could have been caused the malfunctioning memory or CPU.
http://bugs.python.org/issue18843#msg204954
History
Date User Action Args
2013-12-01 20:23:05mmokrejssetmessages: + msg204956
2013-08-30 21:56:13tim.peterssetstatus: open -> closed
resolution: not a bug
messages: + msg196584

stage: resolved
2013-08-30 21:27:16terry.reedysetnosy: + terry.reedy
messages: + msg196579
2013-08-27 00:43:02tim.peterssetmessages: + msg196255
2013-08-26 19:55:46tim.peterssetnosy: + tim.peters
messages: + msg196242
2013-08-26 19:47:06mmokrejscreate