classification
Title: Adding LogRecord attribute "traceback"
Type: enhancement Stage:
Components: Library (Lib) Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Sworddragon, vinay.sajip
Priority: normal Keywords:

Created on 2013-08-24 11:16 by Sworddragon, last changed 2013-09-14 07:27 by vinay.sajip. This issue is now closed.

Messages (2)
msg196072 - (view) Author: (Sworddragon) Date: 2013-08-24 11:16
On configuring a logger with logging.basicConfig() and using logging.exception() the traceback is always written implicitly to the end. This makes it not possible to create a formation that writes something beyond the traceback. For example it could be something like that: logging.basicConfig(filename = '/tmp/python.log', format = '%(asctime)s\n%(traceback)s\nSome_text_or_LogRecords_after_the_traceback', datefmt = '%Y-%m-%d %H:%M:%S')
msg197694 - (view) Author: Vinay Sajip (vinay.sajip) * (Python committer) Date: 2013-09-14 07:27
basicConfig() is for simple usage only. You can use a custom Formatter subclass to meet your specific requirements.
History
Date User Action Args
2013-09-14 07:27:43vinay.sajipsetstatus: open -> closed

nosy: + vinay.sajip
messages: + msg197694

resolution: not a bug
2013-08-24 11:16:56Sworddragoncreate