classification
Title: Need an atexit.register equivalent that also works in subinterps
Type: enhancement Stage: resolved
Components: Interpreter Core, Library (Lib) Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: atexit callbacks should be run at subinterpreter shutdown
View: 31901
Assigned To: Nosy List: christian.heimes, iritkatriel, pitrou, sbt
Priority: low Keywords:

Created on 2013-08-01 17:47 by pitrou, last changed 2021-10-21 15:59 by iritkatriel. This issue is now closed.

Messages (3)
msg194092 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2013-08-01 17:47
Callbacks registered with atexit.register() are only called at shutdown of the main interpreter. For some purposes (perhaps most of them, arguably), you actually want to execute the callbacks at subinterpreter shutdown too.
msg194093 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2013-08-01 18:01
(note that weakref.finalize indirectly suffers from this problem)
msg396585 - (view) Author: Irit Katriel (iritkatriel) * (Python committer) Date: 2021-06-27 15:31
I think this is a duplicate of issue31901.
History
Date User Action Args
2021-10-21 15:59:04iritkatrielsetstatus: open -> closed
superseder: atexit callbacks should be run at subinterpreter shutdown
resolution: duplicate
stage: resolved
2021-06-27 15:31:35iritkatrielsetnosy: + iritkatriel
messages: + msg396585
2013-08-16 15:39:19pitrousetnosy: + christian.heimes
2013-08-01 18:01:02pitrousetmessages: + msg194093
2013-08-01 17:47:58pitrousetpriority: normal -> low
type: enhancement
components: + Interpreter Core, Library (Lib)
versions: + Python 3.4
2013-08-01 17:47:43pitroucreate