classification
Title: Incorect quote marks in code section-headers in PDF version of docs
Type: enhancement Stage:
Components: Documentation Versions: Python 3.3, Python 3.4, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: akuchling, docs@python, ezio.melotti, georg.brandl, icedream91, r.david.murray, tshepang
Priority: normal Keywords:

Created on 2013-06-10 02:03 by icedream91, last changed 2013-10-12 16:26 by georg.brandl. This issue is now closed.

Messages (6)
msg190882 - (view) Author: (icedream91) Date: 2013-06-10 02:03
In library.pdf file(Release 3.3.2, June 09, 2013), I found a typo in page 149: I think the quotation marks are wrong in "datetime.isoformat(sep=’T’)" sentence, they should both be "'".
But it's right in online documents (http://docs.python.org/3/library/datetime.html#datetime.datetime.isoformat).

Thanks.
msg190908 - (view) Author: A.M. Kuchling (akuchling) * (Python committer) Date: 2013-06-10 14:26
Confirmed.  I think this is a general typographic issue in the PDF documentation.  If I cut-and-paste the datetime.isoformat(sep='T') line from the PDF, the single quotes are pasted as U+2019 RIGHT SINGLE QUOTE.  

Looking at the library.tex file built by "make pdflatex", it contains the ASCII single quotes, so LaTeX is responsible for turning the quotes into smart quotes.

I don't know if this is worth fixing and can see arguments both ways.  The smart quotes are readable and I doubt a reader will be confused and try to actually type them in their source code.  OTOH it's annoying that cut-and-pasting code from the PDFs won't work.
msg190910 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-06-10 14:38
I presume that tex doesn't do quote-transformation on code blocks (it is not really smart quotes, since IIRC in tex you actually have to specify ` and ' in the correct places yourself).  So perhaps the problem is that the function headers &c aren't being properly marked up as code in the latex output engine of Sphinx?
msg199354 - (view) Author: Tshepang Lekhonkhobe (tshepang) * Date: 2013-10-09 22:45
A work-around: http://stackoverflow.com/a/16164658/321731.
msg199433 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2013-10-11 01:23
Should this be moved to the Sphinx bug tracker?
msg199591 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2013-10-12 16:26
Yes, there is already one or two issues there (e.g. number 1239).
History
Date User Action Args
2013-10-12 16:26:00georg.brandlsetstatus: pending -> closed
resolution: not a bug
messages: + msg199591
2013-10-11 01:23:10ezio.melottisetstatus: open -> pending
nosy: + georg.brandl
messages: + msg199433

2013-10-09 22:45:35tshepangsetmessages: + msg199354
versions: + Python 2.7
2013-08-27 02:57:46tshepangsetnosy: + tshepang
2013-06-15 21:21:25ezio.melottisetnosy: + ezio.melotti

type: enhancement
versions: + Python 3.4
2013-06-10 14:39:00r.david.murraysettitle: Typo in Documents -> Incorect quote marks in code section-headers in PDF version of docs
2013-06-10 14:38:17r.david.murraysetnosy: + r.david.murray
messages: + msg190910
2013-06-10 14:26:02akuchlingsetnosy: + akuchling
messages: + msg190908
2013-06-10 02:03:00icedream91create