classification
Title: IDLE 3.3.2 Windows taskbar icon needs reboot after install
Type: Stage: resolved
Components: Installation, Windows Versions: Python 3.5
process
Status: closed Resolution: postponed
Dependencies: Superseder:
Assigned To: Nosy List: loewis, roger.serwy, steve.dower, terry.reedy
Priority: normal Keywords:

Created on 2013-05-24 23:21 by terry.reedy, last changed 2014-10-03 01:56 by terry.reedy. This issue is now closed.

Messages (11)
msg189937 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-05-24 23:21
Windows 7 (32 bit?), 32 bit IDLE 3.3.2: When I start from the start menu, the taskbar icon is the red Tk icon instead of the IDLE icon. If I try to pin the Tk icon to the task bar, a useless pythonw icon is pinned instead. The Tk icon goes when the program is closed. After multiple open and frequent program deletions, Idle shows up on the Start/frequent programs list with it normal Idle icon (White page + snake).

(I had 3.3.1 before working fine. The 3.3.2 upgrade did not work (tkinter would not import, so I redownloaded, deleted Python 3.3.2, and reinstalled, getting the behavior above.)

I have seen the Tk icon before after fresh installs, but on other machines, and it was replaced after the first open with the correct icon.
msg190116 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-05-26 21:05
Restarting Windows solves the issue. If nothing else, the installer could end with 'Restart Windows for Idle icons to work correctly'.
msg190269 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2013-05-29 03:53
For me, 3.3.2 32-bit won't pin to the taskbar, but 3.3.1 can. Running lnk-parser on the .lnk files for IDLE reveal no obvious differences.
msg190276 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2013-05-29 07:23
I can't reproduce the issue it all; IDLE just readily pins to the task bar with the correct icon. Can somebody please provide exact steps to reproduce?
msg190280 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-05-29 09:39
All I did was install (standard, all users) and start Idle without rebooting. Problem goes away after reboot. This happened on previous versions with different hardware.
msg190338 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2013-05-30 05:35
I'm running Win7 64-bit in a VM. The steps for me was to start with a system without any Python version installed. Install 3.3.1 32-bit, and then install 3.3.2 32-bit. IDLE launches with a red Tk icon and pinning it to the task bar does not actually pin IDLE. A reboot does fix the issue, as Terry observed.
msg190377 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2013-05-30 18:49
I can now reproduce it, and asked on SO (http://stackoverflow.com/questions/16843727/)
msg212319 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-02-26 22:52
The last installation I did now said to reboot to finish the installation, but I forget which it was. Since that was my alternative fix, this could perhaps be closed. I will try to check the coming installs.
msg228272 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-10-02 22:33
Steve, would it possible for the installer to tell users to Restart to get (Idle) icons working properly?  (Assuming that this cannot be made unnecessary.)
msg228279 - (view) Author: Steve Dower (steve.dower) * (Python committer) Date: 2014-10-02 23:27
This is probably because the program items are advertised. I have 2.7 and 3.3 installed, and when I pin the 3.3 Idle it switches to the 2.7 one. I guess there's a GUID somewhere that makes the two icons identical, but I don't know where that would be. This probably causes the icon cache issue (which I also see with 3.3.1->3.3.2).

The 3.5 installer will not use advertised shortcuts, so they'll be direct links to the exact version of the launch script. This should cut out a whole range of conflicts between different installs.

In any case, suggesting a reboot just for an icon is not a great look. It's bad enough that we require admin privileges for a per-user install (also on my list...). Hopefully the change to non-advertised shortcuts will fix it, but otherwise it probably doesn't need more than a note on the last page of the installer (which nobody ever reads, but short of forcing unnecessary reboots there's not much we can do about that).
msg228291 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2014-10-03 01:56
Thanks for the reply.  I am assuming that you do not need this open as a reminder. So I will close it and wait for 3.5.
History
Date User Action Args
2014-10-03 01:56:39terry.reedysetstatus: open -> closed
versions: + Python 3.5, - Python 3.3
messages: + msg228291

resolution: postponed
stage: needs patch -> resolved
2014-10-02 23:27:28steve.dowersetmessages: + msg228279
2014-10-02 22:33:51terry.reedysettitle: IDLE 3.3.2 Windows taskbar icon regression -> IDLE 3.3.2 Windows taskbar icon needs reboot after install
nosy: + steve.dower

messages: + msg228272

components: - IDLE
2014-02-26 22:52:27terry.reedysetmessages: + msg212319
2013-05-30 18:49:52loewissetmessages: + msg190377
2013-05-30 05:35:04roger.serwysetmessages: + msg190338
2013-05-29 09:39:49terry.reedysetmessages: + msg190280
2013-05-29 07:23:55loewissetmessages: + msg190276
2013-05-29 03:53:19roger.serwysetmessages: + msg190269
2013-05-26 21:05:17terry.reedysetmessages: + msg190116
2013-05-24 23:21:33terry.reedycreate