classification
Title: Doc issue with threading.Event
Type: enhancement Stage: resolved
Components: Documentation Versions: Python 3.2
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, ezio.melotti, mjpieters, r.david.murray, xordoquy
Priority: normal Keywords: easy

Created on 2013-04-30 06:06 by xordoquy, last changed 2014-12-16 23:49 by mjpieters. This issue is now closed.

Messages (5)
msg188127 - (view) Author: Xavier Ordoquy (xordoquy) Date: 2013-04-30 06:06
The documentation isn't correct for the threading.Event class under python 3.2.

In the threading doc page (http://docs.python.org/3.2/library/threading.html), Event is said to be at the same time a function and a class.

This is misleading and lead to a regression for celery under python 3.2 (https://github.com/celery/celery/pull/1333).

Could the doc be updated under python 3.2 so that threading.Event leads to the function and threading._Event leads to the class ?

Regards,
Xavier.
msg188166 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-04-30 14:16
I'm sorry, the 3.2 docs are no longer updated.  The effective way to become aware of these changes between versions is via the 'version changed' tags in the new documentation.  You will note that these tags exist in the 3.3 docs.
msg232769 - (view) Author: Martijn Pieters (mjpieters) * Date: 2014-12-16 23:29
I notice that the same issue still exists in the 3.5 documentation. Surely this can at least be fixed in the development copy?
msg232773 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2014-12-16 23:48
If there really is an issue in the 3.4/3.5 docs, you should open an new issue explaining what the problem is.  In 3.4/3.5, Event is a class, not a function, and is documented accordingly.
msg232775 - (view) Author: Martijn Pieters (mjpieters) * Date: 2014-12-16 23:49
Ah! Mea Culpa, you are correct. The issue is then with Python 2.7 only for which no doubt exists a separate ticket.
History
Date User Action Args
2014-12-16 23:49:47mjpieterssetmessages: + msg232775
2014-12-16 23:48:12r.david.murraysetmessages: + msg232773
2014-12-16 23:29:00mjpieterssetnosy: + mjpieters
messages: + msg232769
2013-04-30 14:16:24r.david.murraysetstatus: open -> closed

nosy: + r.david.murray
messages: + msg188166

resolution: out of date
stage: needs patch -> resolved
2013-04-30 07:21:49ezio.melottisetkeywords: + easy
nosy: + ezio.melotti

stage: needs patch
2013-04-30 06:06:25xordoquycreate