This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Title: pythonw.exe crashes on opening IDLE
Type: crash Stage:
Components: IDLE, Windows Versions: Python 3.3
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: Acebulf, amaury.forgeotdarc, roger.serwy
Priority: normal Keywords:

Created on 2013-04-08 03:51 by Acebulf, last changed 2022-04-11 14:57 by admin. This issue is now closed.

File name Uploaded Description Edit
WER1B0A.tmp.WERInternalMetadata.xml Acebulf, 2013-04-08 03:51
WER5D77.tmp.appcompat.txt Acebulf, 2013-04-08 03:52
WER5EA0.tmp.mdmp Acebulf, 2013-04-08 03:52
Messages (8)
msg186268 - (view) Author: Patrick Poitras (Acebulf) Date: 2013-04-08 03:51
I just installed Python 3.3.1, and tried to open IDLE, which failed to come up, giving only the classic pythonw.exe has stopped responding.

Will post dumps.
msg186269 - (view) Author: Patrick Poitras (Acebulf) Date: 2013-04-08 04:02
So I tried to open Python33\python.exe and it's trying to load codecs from Python 2.7 which I think has to be the cause of the problem. When it raises CodecRegistryError, the 2.7 syntax is wrong for 3.3 and causes a SyntaxError.

Fatal Python error: Py_Initialize: unable to load system file codec
  File "C:\Python27\Lib\encodings\", line 123
    raise CodecRegistryError,\

SyntaxError: invalid syntax
msg186299 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2013-04-08 13:06
Hum, do you have any environment variable that refer to Python27?
In a terminal window (cmd.exe), try the following command:
  set | findstr /i python
msg186306 - (view) Author: Patrick Poitras (Acebulf) Date: 2013-04-08 15:18
It returns this:

C:\Users\Acebulf>set | findstr /i python
Path=C:\Python27\Lib\site-packages\PyQt4;C:\Program Files (x86)\NVIDIA Corporati
ws\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\WiFi\bin\;C:\Program
Files\Common Files\Intel\WirelessCommon\;C:\Program Files\Microsoft SQL Server\1
10\Tools\Binn\;C:\Program Files (x86)\MiKTeX 2.9\miktex\bin\;C:\Program Files\In
tel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Python27\
msg186312 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2013-04-08 15:39
Please remove the PYTHONPATH environment variable.

I don't know how it came here, but it's certainly not needed: these directories are computed at runtime when the python27 interpreter starts;
it can only do harm when another interpreter is installed.
msg189722 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2013-05-21 03:42
Patrick, does removing PYTHONPATH from your environment variables fix this problem?
msg190046 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2013-05-26 01:08
I'm closing this issue due since it's root problem is a misconfigured environment variable.
msg190047 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2013-05-26 01:10
Date User Action Args
2022-04-11 14:57:44adminsetgithub: 61858
2013-05-26 01:10:15roger.serwysetmessages: + msg190047
2013-05-26 01:08:31roger.serwysetstatus: pending -> closed
resolution: works for me
messages: + msg190046
2013-05-21 03:42:15roger.serwysetstatus: open -> pending
nosy: + roger.serwy
messages: + msg189722

2013-04-08 15:39:16amaury.forgeotdarcsetmessages: + msg186312
2013-04-08 15:18:26Acebulfsetmessages: + msg186306
2013-04-08 13:06:45amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg186299
2013-04-08 04:02:30Acebulfsetmessages: + msg186269
2013-04-08 03:52:38Acebulfsetfiles: + WER5EA0.tmp.mdmp
2013-04-08 03:52:18Acebulfsetfiles: + WER5D77.tmp.appcompat.txt
2013-04-08 03:51:55Acebulfcreate