classification
Title: segfaults during serialization
Type: crash Stage: resolved
Components: Extension Modules Versions: Python 2.7
process
Status: closed Resolution: works for me
Dependencies: Superseder:
Assigned To: Nosy List: alexandre.vassalotti, barry, benjamin.peterson, eddiewrc, vstinner
Priority: normal Keywords:

Created on 2013-03-27 23:34 by eddiewrc, last changed 2013-05-03 00:51 by alexandre.vassalotti. This issue is now closed.

Files
File name Uploaded Description Edit
ModelSettings.py eddiewrc, 2013-03-27 23:34
Messages (5)
msg185389 - (view) Author: Daniele Raimondi (eddiewrc) Date: 2013-03-27 23:34
pickle and cPickle cause really often segfaults when dumping or loading user defined classes. It happens with python 2.7.3 on 64bits architecture, with any protocol (0,1,2).
I attach an example of class afflicted by this problem.
Solutions anyone?
msg185390 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2013-03-28 00:03
Please provide a self-contained explain, we can reproduce.
msg185395 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-03-28 00:51
ModelSettings.py requires globalSettings which is not attached.
msg185406 - (view) Author: Daniele Raimondi (eddiewrc) Date: 2013-03-28 08:34
I'll try ASAP.
unfortunately I'm pretty busy trying to overcome this problem

On Thu, Mar 28, 2013 at 1:51 AM, STINNER Victor <report@bugs.python.org>wrote:

>
> STINNER Victor added the comment:
>
> ModelSettings.py requires globalSettings which is not attached.
>
> ----------
> nosy: +haypo
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue17565>
> _______________________________________
>
msg188285 - (view) Author: Alexandre Vassalotti (alexandre.vassalotti) * (Python committer) Date: 2013-05-03 00:51
If you are pickling large objects, you're likely hitting issue #11872. We fixed most 64-bit issues in Python 3, so upgrading might be solution if possible.

Since the particular bug you are hitting cannot be reproduced with your test case, I am closing this issue. Feel free to reopen if you come up with a reproducible test case.
History
Date User Action Args
2013-05-03 00:51:43alexandre.vassalottisetstatus: open -> closed

type: crash

nosy: + alexandre.vassalotti
messages: + msg188285
resolution: works for me
stage: resolved
2013-03-29 03:25:42barrysetnosy: + barry
2013-03-28 08:34:40eddiewrcsetmessages: + msg185406
2013-03-28 00:51:30vstinnersetnosy: + vstinner
messages: + msg185395
2013-03-28 00:03:31benjamin.petersonsetnosy: + benjamin.peterson
messages: + msg185390
2013-03-27 23:34:55eddiewrccreate