classification
Title: -m broken in trunk
Type: Stage:
Components: Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: christian.heimes Nosy List: christian.heimes, georg.brandl, giampaolo.rodola, gvanrossum
Priority: critical Keywords:

Created on 2008-01-07 18:58 by gvanrossum, last changed 2019-04-09 02:46 by giampaolo.rodola. This issue is now closed.

Messages (5)
msg59478 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2008-01-07 18:58
As of today, the -m option doesn't appear to work any more in the trunk.
 I get this error:

$ ./python -m string
Could not import runpy module
$

However it seems to be confused:

$ ./python -c 'import runpy'
$

IOW the module imports just fine.

Crys, I wonder if this has to do with your import-nolock changes?
msg59479 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2008-01-07 18:59
Seems to work here...
msg59480 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2008-01-07 19:09
Bah.  Environment error.  Sorry!
msg339693 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2019-04-09 02:42
New changeset 8702b67dad62a9084f6c1823dce10653743667c8 by Giampaolo Rodola in branch 'master':
BPO-17561: set create_server backlog default to None (GH-12735)
https://github.com/python/cpython/commit/8702b67dad62a9084f6c1823dce10653743667c8
msg339695 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2019-04-09 02:46
Sorry, I accidentally referenced this BPO issue in my commit.
History
Date User Action Args
2019-04-09 02:46:55giampaolo.rodolasetmessages: + msg339695
2019-04-09 02:42:16giampaolo.rodolasetnosy: + giampaolo.rodola
messages: + msg339693
2008-01-07 19:09:36gvanrossumsetstatus: open -> closed
resolution: not a bug
messages: + msg59480
2008-01-07 18:59:02georg.brandlsetnosy: + georg.brandl
messages: + msg59479
2008-01-07 18:58:01gvanrossumcreate