classification
Title: Modules/ld_so_aix needs to strip path off of whichcc call
Type: behavior Stage: resolved
Components: Build Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ajaksu2, bhochste, loewis
Priority: low Keywords:

Created on 2007-06-08 13:52 by bhochste, last changed 2009-04-25 21:44 by ajaksu2. This issue is now closed.

Messages (3)
msg32264 - (view) Author: Brad Hochstetler (bhochste) Date: 2007-06-08 13:52
In the shell, sh, which is used by ld_so_aix when doing the call 

whichcc=`which $CC`

extraneous data could be added on before the path to the compiler, i.e.
ARCH = rs6000, openwin = 1, term = xterm, shell = csh
/usr/vacpp/bin/cc


would be nice to have the script check for anything extra and strip it off.




msg32265 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-06-08 17:25
Can you please provide a patch?
msg84733 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-03-31 00:48
I'll close this unless opposition is voiced.
History
Date User Action Args
2009-04-25 21:44:34ajaksu2setstatus: pending -> closed
resolution: not a bug
stage: test needed -> resolved
2009-03-31 00:48:02ajaksu2setstatus: open -> pending
priority: normal -> low
type: behavior


nosy: + ajaksu2
messages: + msg84733
stage: test needed
2007-06-08 13:52:55bhochstecreate