classification
Title: OrderedDict not ordering properly when int and float keys are used
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 3.2
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: MrDrMcNinja, benjamin.peterson
Priority: normal Keywords:

Created on 2013-02-20 23:34 by MrDrMcNinja, last changed 2013-02-21 06:58 by ezio.melotti. This issue is now closed.

Files
File name Uploaded Description Edit
OrderedDictBug.png MrDrMcNinja, 2013-02-20 23:34
Messages (3)
msg182570 - (view) Author: Mrdrmcninja (MrDrMcNinja) Date: 2013-02-20 23:34
I've got two lists:

state_cns_list = [0.001, 1, 2, 5]
state_names_list = [L, S, D, H]

When I try to create an OrderedDict linking each state_cns_list entry with its corresponding state_names_list entry, like so:

states = OrderedDict( {float(state_cns_list[i]): state_names_list[i] for i in range(0, len(state_cns_list) ) } )

rather than maintaining the original order, (0.001, 'L') is placed at the end of the OrderedDict instead of at the beginning. The attached screenshot shows the bug in action.

Although it's not in the screenshot, when I try placing 4 integers into state_cns_list instead of 3 integers and a float, it has no problem correctly ordering them.
msg182571 - (view) Author: Benjamin Peterson (benjamin.peterson) * (Python committer) Date: 2013-02-20 23:35
The dictionary you pass to the OrderedDict constructor has already lost the order you initialize it with.
msg182572 - (view) Author: Mrdrmcninja (MrDrMcNinja) Date: 2013-02-20 23:36
Ahh nevermind, just realized my error :P Sorry for the waste of internet space
History
Date User Action Args
2013-02-21 06:58:02ezio.melottisetstage: resolved
2013-02-20 23:36:30MrDrMcNinjasetmessages: + msg182572
2013-02-20 23:35:53benjamin.petersonsetstatus: open -> closed

nosy: + benjamin.peterson
messages: + msg182571

resolution: not a bug
2013-02-20 23:34:31MrDrMcNinjacreate