classification
Title: Py_SIZE() macro used as an lvalue
Type: Stage:
Components: Interpreter Core Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: loewis Nosy List: loewis, rhettinger
Priority: normal Keywords:

Created on 2008-01-02 23:43 by rhettinger, last changed 2008-01-02 23:46 by loewis. This issue is now closed.

Messages (2)
msg59111 - (view) Author: Raymond Hettinger (rhettinger) * (Python committer) Date: 2008-01-02 23:43
Don't know if this was intended.  Here's a example from rev 56476 in
arraymodule.c:

-       op->ob_size = size;
+       Py_Size(op) = size;
msg59112 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2008-01-02 23:46
Certainly. This macro definitely *is* an lvalue.
History
Date User Action Args
2008-01-02 23:46:36loewissetstatus: open -> closed
resolution: not a bug
messages: + msg59112
2008-01-02 23:43:19rhettingercreate