classification
Title: os.path.isfile() in Python 3.3 sometimes fails
Type: behavior Stage:
Components: Library (Lib) Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Malfunctioning compiled code in Python 3.3 x64
View: 17137
Assigned To: Nosy List: georg.brandl, gpoore, terry.reedy, vstinner
Priority: normal Keywords:

Created on 2013-02-15 22:49 by gpoore, last changed 2013-10-13 18:22 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
os-path-issue-3-3.py gpoore, 2013-02-15 22:49 Script to demonstrate issue
Messages (4)
msg182188 - (view) Author: G. Poore (gpoore) Date: 2013-02-15 22:49
os.path.isfile() sometimes incorrectly reports that a file does not exist under Python 3.3 (only tested under Windows).  This may be encoding related.  The issue only appears under a very particular set of circumstances; see comments in the attached script.  The attached script demonstrates the issue by testing for an arbitrary file x.txt (you will need to create a file with that name for the test script to work).
msg182288 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2013-02-17 22:24
Looks like a duplicate of issue #17137.
Le 17 févr. 2013 23:08, "Antoine Pitrou" <report@bugs.python.org> a écrit :

>
> Changes by Antoine Pitrou <pitrou@free.fr>:
>
>
> ----------
> nosy: +haypo
>
> _______________________________________
> Python tracker <report@bugs.python.org>
> <http://bugs.python.org/issue17212>
> _______________________________________
>
msg182677 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-02-22 17:32
#17137 has a patch that will be in 3.3.1, coming soon we hope. If you cannot build Python on Windows, please retest with the new release.
msg199748 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2013-10-13 18:22
Closing due to lack of feedback.
History
Date User Action Args
2013-10-13 18:22:37georg.brandlsetstatus: pending -> closed
nosy: + georg.brandl
messages: + msg199748

2013-02-22 21:16:56ezio.melottisetstatus: open -> pending
superseder: Malfunctioning compiled code in Python 3.3 x64
resolution: duplicate
2013-02-22 17:32:59terry.reedysetnosy: + terry.reedy
messages: + msg182677
2013-02-17 22:24:16vstinnersetmessages: + msg182288
2013-02-17 22:08:20pitrousetnosy: + vstinner
2013-02-15 22:49:58gpoorecreate