classification
Title: Tk() not defined in Tkinter module
Type: compile error Stage:
Components: Tkinter Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: georg.brandl, r.david.murray, zephyr
Priority: normal Keywords:

Created on 2013-02-02 09:28 by zephyr, last changed 2013-10-13 17:57 by georg.brandl. This issue is now closed.

Messages (3)
msg181153 - (view) Author: (zephyr) Date: 2013-02-02 09:28
There are two cases of this issues:

1)Terminal-importing the Tkinter module and creating a Tk() object runs fine for the first instance but exiting the interpreter and trying to create a object for the next instance gives error:'Tk() is not defined'

2)IDE-importing the Tkinter module and creating a Tk() object produces error-'Tk() is not defined'.
msg181169 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-02-02 14:21
Please provide a complete example of the failures.  Your report doesn't currently provide enough information to reproduce the reported issue.

If the reported error message is accurate, it looks at first glance like the error message at least could use some improvement, since (at least as a non-tkinter user) I have no idea what it would mean for Tk() to be defined, since it isn't a Python identifier.  On the other hand, if that error message comes from Tk itself and not Python, then it is probably correct.
msg199739 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2013-10-13 17:57
Closing due to lack of feedback.
History
Date User Action Args
2013-10-13 17:57:07georg.brandlsetstatus: pending -> closed

nosy: + georg.brandl
messages: + msg199739

resolution: not a bug
2013-09-15 15:53:55serhiy.storchakasetstatus: open -> pending
components: + Tkinter, - None
2013-02-02 14:21:20r.david.murraysetnosy: + r.david.murray
messages: + msg181169
2013-02-02 09:28:36zephyrcreate