classification
Title: ampersand "&" in path prevents compilation of Python
Type: compile error Stage:
Components: Build Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: georg.brandl, gheorghe.mosteoru
Priority: normal Keywords:

Created on 2013-02-02 09:22 by gheorghe.mosteoru, last changed 2013-03-28 10:15 by georg.brandl. This issue is now closed.

Messages (3)
msg181151 - (view) Author: gheorghe mosteoru (gheorghe.mosteoru) Date: 2013-02-02 09:22
I've be trying to compile python in a folder which had '&' (ampersand) in the path and i couldn't. 

First configure got some weird output:

configure: creating ./config.status
config.status: creating Makefile.pre
sed: -e expression #1, char 435: unknown option to `s'
config.status: creating Modules/Setup.config
sed: -e expression #1, char 447: unknown option to `s'
config.status: creating Misc/python.pc
sed: -e expression #1, char 438: unknown option to `s'
config.status: creating Misc/python-config.sh
sed: -e expression #1, char 452: unknown option to `s'
config.status: creating Modules/ld_so_aix
sed: -e expression #1, char 441: unknown option to `s'
config.status: creating pyconfig.h
creating Modules/Setup
creating Modules/Setup.local
creating Makefile

Then when I've run make I've got:

make: *** No rule to make target `/Modules/posixmodule.c', needed by `Modules/posixmodule.o'.  Stop.
msg181165 - (view) Author: gheorghe mosteoru (gheorghe.mosteoru) Date: 2013-02-02 12:41
I think this might be a bug in autoconf:

http://lists.gnu.org/archive/html/bug-autoconf/2012-08/msg00000.html


The latest version of autoconf gives me a message when I try to run configure (for autoconf code itself) in that directory

checking whether build environment is sane... configure: error: unsafe absolute working directory name
msg185418 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2013-03-28 10:15
Closing as this is a bug in autoconf.  2.69 is still the latest released version, so we'll get the fix whenever the new version is out and sufficiently widely distributed.
History
Date User Action Args
2013-03-28 10:15:26georg.brandlsetstatus: pending -> closed

nosy: + georg.brandl
messages: + msg185418

resolution: not a bug
2013-02-14 14:19:10ezio.melottisetstatus: open -> pending
2013-02-04 13:36:09Ramchandra Aptesettitle: ampersand "&" in path prevents from compiling pthon -> ampersand "&" in path prevents compilation of Python
2013-02-02 12:41:21gheorghe.mosteorusetmessages: + msg181165
2013-02-02 09:22:38gheorghe.mosteorucreate