classification
Title: Document that bytes OS API can returns unusable results on Windows
Type: enhancement Stage: needs patch
Components: Documentation, Windows Versions: Python 2.7
process
Status: open Resolution:
Dependencies: Superseder:
Assigned To: docs@python Nosy List: barry, docs@python, serhiy.storchaka, stevenk, vstinner
Priority: normal Keywords: easy

Created on 2012-12-16 16:58 by serhiy.storchaka, last changed 2017-10-22 07:52 by serhiy.storchaka.

Messages (7)
msg177613 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2012-12-16 16:58
Some OS functions which returns bytes (os.environb, os.getenvb(), os.getcwdb(), os.listdir(), os.readlink(), os.walk(), os.path.abspath(), os.path.expanduser(), os.path.expandvars(), os.path.realpath() and may be other) can return unusable result on Windows (see for example issue13247 and issue16656). The documentation should contains strong warnings about this.
msg177624 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2012-12-16 19:49
I don't remember il the deprecation of bytes filename is documented.
msg228370 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-10-03 20:28
As #13247 has been closed "not a bug" and #16656 "won't fix" shouldn't this be done sooner rather than later?
msg275892 - (view) Author: Steve Kowalik (stevenk) Date: 2016-09-12 00:07
I've looked at the documentation for both Python 3.5 and 3.6, and I think this is all fine -- things like os.environb and os.getcwdb() are clearly stated as not available on Windows, and the path functions look to work fine in my testing.
msg275893 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2016-09-12 00:07
Thanks Steve!  Closing.
msg276740 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2016-09-16 19:14
Maybe this issue is outdated in 3.6 (thanks to PEP 529), but this still is a problem under 3.5 and 2.7.
msg304732 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2017-10-22 07:52
This is now 2.7 only issue.
History
Date User Action Args
2017-10-22 07:52:54serhiy.storchakasetmessages: + msg304732
2017-10-22 07:40:26serhiy.storchakasetversions: - Python 3.5
2016-09-16 21:16:35BreamoreBoysetnosy: - BreamoreBoy
2016-09-16 19:14:15serhiy.storchakasetstatus: closed -> open

messages: + msg276740
versions: + Python 3.5, - Python 3.3, Python 3.4
2016-09-12 00:07:55barrysetstatus: open -> closed
nosy: + barry
messages: + msg275893

2016-09-12 00:07:12stevenksetnosy: + stevenk
messages: + msg275892
2014-10-03 20:28:34BreamoreBoysetnosy: + BreamoreBoy
messages: + msg228370
2013-08-22 09:08:49serhiy.storchakasetversions: - Python 3.2
2013-01-15 18:28:12serhiy.storchakasetkeywords: + easy
2012-12-16 19:49:43vstinnersetmessages: + msg177624
2012-12-16 17:07:06pitrousetnosy: + vstinner
2012-12-16 16:58:37serhiy.storchakacreate