classification
Title: Remove python3dll.vcxproj from pcbuild.sln
Type: Stage:
Components: Build Versions: Python 3.2, Python 3.3, Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: trent Nosy List: brian.curtin, christian.heimes, jkloth, loewis, trent
Priority: normal Keywords:

Created on 2012-12-12 11:43 by trent, last changed 2012-12-12 18:02 by trent. This issue is now closed.

Messages (3)
msg177372 - (view) Author: Trent Nelson (trent) * (Python committer) Date: 2012-12-12 11:43
As far as I can tell, the python3dll.vcxproj is bitrot and should be removed from pcbuild.sln.  It's a makefile target project that invokes ..\PC\python3.mak, which builds a target named python3.dll; however, pythoncore.vxcproj builds python34[_d].dll as a proper VS project.

(Additionally, the python3dll.vxcproj has no Debug configuration, which is what brought it to my attention in the first place.)

Christian/Martin: is this python3dll.vcxproj and resulting python3.dll still used or can it be safely removed from pcbuild.sln?
msg177380 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-12-12 16:39
Yes, it's still used. python3.dll is different from python3X.dll, and specified in PEP 384. It will remain in Python until Python 4 comes along (and then likely be replaced by python4.dll).
msg177383 - (view) Author: Trent Nelson (trent) * (Python committer) Date: 2012-12-12 18:02
Thanks Martin, I wasn't aware of that PEP.  Explains why there isn't a debug configuration, too.
History
Date User Action Args
2012-12-12 18:02:54trentsetmessages: + msg177383
2012-12-12 16:39:59loewissetstatus: open -> closed
resolution: not a bug
messages: + msg177380
2012-12-12 16:38:24jklothsetnosy: + jkloth
2012-12-12 14:14:51trentsetnosy: + brian.curtin
2012-12-12 11:43:10trentcreate