classification
Title: test_shutil: 2 failures related to symlinks
Type: Stage:
Components: Windows Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: test_shutil fails with symlinks enabled under Windows
View: 13837
Assigned To: Nosy List: loewis, pitrou, tim.golden, vstinner
Priority: normal Keywords:

Created on 2012-11-05 00:47 by vstinner, last changed 2012-11-05 07:06 by pitrou. This issue is now closed.

Messages (3)
msg174856 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2012-11-05 00:47
======================================================================
FAIL: test_copymode_follow_symlinks (test.test_shutil.TestShutil)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\victor\default\lib\test\test_shutil.py", line 258, in test_copymode_f
ollow_symlinks
    self.assertEqual(os.stat(src).st_mode, os.stat(dst).st_mode)
AssertionError: 33206 != 33060

======================================================================
FAIL: test_move_dangling_symlink (test.test_shutil.TestMove)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "C:\victor\default\lib\test\test_shutil.py", line 60, in wrap
    return func(*args, **kwargs)
  File "C:\victor\default\lib\test\test_shutil.py", line 1435, in test_move_dang
ling_symlink
    self.assertEqual(os.path.realpath(src), os.path.realpath(dst_link))
AssertionError: 'c:\\users\\haypo\\appdata\\local\\temp\\tmpmhpdb_\\baz' != 'c:\
\users\\haypo\\appdata\\local\\temp\\tmpnsjap0\\quux'
- c:\users\haypo\appdata\local\temp\tmpmhpdb_\baz
?                                      ^^ ^^^ ^^^
+ c:\users\haypo\appdata\local\temp\tmpnsjap0\quux
?                                      ^^^^ ^ ^^^^
msg174857 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2012-11-05 00:53
I ran test_shutil on Windows 7 with NTFS.
msg174867 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-11-05 07:06
Duplicate of #13837.
History
Date User Action Args
2012-11-05 07:06:35pitrousetstatus: open -> closed
resolution: duplicate
superseder: test_shutil fails with symlinks enabled under Windows
messages: + msg174867
2012-11-05 00:54:08vstinnersetnosy: + loewis, pitrou, tim.golden
2012-11-05 00:53:51vstinnersetmessages: + msg174857
2012-11-05 00:47:25vstinnercreate