classification
Title: can't print figures 08 and 09
Type: behavior Stage: resolved
Components: None Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: ezio.melotti, jose.gregorio.fernandez.trincado
Priority: normal Keywords:

Created on 2012-10-29 16:28 by jose.gregorio.fernandez.trincado, last changed 2012-10-29 16:32 by ezio.melotti. This issue is now closed.

Messages (2)
msg174126 - (view) Author: jose gregorio fernandez trincado (jose.gregorio.fernandez.trincado) Date: 2012-10-29 16:28
In [2]: 09
  File "<ipython-input-2-7010843e6b42>", line 1
    09
     ^
SyntaxError: invalid token

Using str() produce SyntaxError too. The same for 08. Figures like 01 and 02 produce the appropriate output.

Hardware: Lenovo 3000 N200, 80Gb of HD, 4Gb of RAM, Core-Duo 2.6GHz
OS: Ubuntu 12.04, 64bits.
msg174127 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2012-10-29 16:32
Those are invalid octal literals, since the digits 8 and 9 don't exist in octal.
See http://docs.python.org/2/reference/lexical_analysis.html#grammar-token-octinteger
History
Date User Action Args
2012-10-29 16:32:40ezio.melottisetstatus: open -> closed

nosy: + ezio.melotti
messages: + msg174127

resolution: not a bug
stage: resolved
2012-10-29 16:28:41jose.gregorio.fernandez.trincadocreate