classification
Title: email cannot be imported
Type: behavior Stage:
Components: Library (Lib) Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Wubbulous, amaury.forgeotdarc, brett.cannon, gvanrossum
Priority: normal Keywords:

Created on 2007-12-15 03:55 by Wubbulous, last changed 2007-12-18 19:31 by gvanrossum. This issue is now closed.

Messages (6)
msg58652 - (view) Author: (Wubbulous) Date: 2007-12-15 03:55
Python will not load the email module or any of its child modules.
msg58657 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2007-12-15 05:41
More detail is needed than this in order to try to fix this.  What error
message are you getting?  What OS?  What exact version of Python?  Is
this a binary distro or a source one?

Since all releases are thoroughly tested and never had any import issues
with the email code chances are there is a problem with your environment
and not Python.
msg58679 - (view) Author: (Wubbulous) Date: 2007-12-16 23:45
I have attempted the following separately: import email   import 
email.Utils    import email.utils

they each return the error:
Traceback (most recent call last):

  File "C:\Panda3D-1.4.2\python\lib\smtplib.py", line 49, in ?
    from email.base64MIME import encode as encode_base64
ImportError: No module named base64MIME
msg58681 - (view) Author: Brett Cannon (brett.cannon) * (Python committer) Date: 2007-12-17 02:07
I just noticed that the directory you are executing from is Panda3D. 
Did you not download Python directly but are using the one from Panda3D?
msg58686 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2007-12-17 08:51
But the email package does not import smtplib (the dependency is the
other way). Can you please try with the command:
  import email
and paste the whole traceback?
msg58757 - (view) Author: Guido van Rossum (gvanrossum) * (Python committer) Date: 2007-12-18 19:31
Let's not waste time in the bug tracker debugging some user's broken
setup.  Let him contact Panda3D's customer support.
History
Date User Action Args
2007-12-18 19:31:34gvanrossumsetstatus: pending -> closed
nosy: + gvanrossum
resolution: not a bug
messages: + msg58757
2007-12-17 08:51:19amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg58686
2007-12-17 02:07:41brett.cannonsetmessages: + msg58681
2007-12-16 23:45:02Wubbuloussetmessages: + msg58679
severity: major -> normal
2007-12-15 18:14:43georg.brandlsetstatus: open -> pending
2007-12-15 05:41:55brett.cannonsettitle: email -> email cannot be imported
2007-12-15 05:41:38brett.cannonsetnosy: + brett.cannon
messages: + msg58657
2007-12-15 03:55:52Wubbulouscreate