classification
Title: MacInstalls break PyDev
Type: Stage: resolved
Components: macOS Versions: Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: ronaldoussoren Nosy List: Doug.Ransom, ned.deily, ronaldoussoren
Priority: normal Keywords:

Created on 2012-10-12 13:54 by Doug.Ransom, last changed 2012-10-15 07:52 by ronaldoussoren. This issue is now closed.

Messages (6)
msg172743 - (view) Author: Doug Ransom (Doug.Ransom) Date: 2012-10-12 13:54
A number of .py files are not installed in the mac installer.  While python programs run OK, this thwarts users from using IDEs like Aptana Studio/PyDev.  For those of us who are python dabblers, this makes it nearly impossible to write/debug python code.

urllib.py is an example.

Here is the note from PyDev which works with Aptana Studio http://pydev.org/manual_101_interpreter.html (though installing python as they discuss doesn't fix the problem, and the /lib folder thing is probably beyond most of us to figure out):

"IMPORTANT for Mac users: The Python version that usually ships with Mac doesn't seem to have the .py source files 
available, which are required for PyDev, so, using a different interpreter is recommended (i.e.: Download it from http://python.org). If you don't want to use a different interpreter, get the source files for the Python '/Lib' folder
and add those to the system installation.

After those steps, you should have a screen as presented below:..."

How about changing the install so IDEs like pydev, for all versions?  A few extra bytes of disk space probably won't harm anything.
msg172744 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2012-10-12 14:00
The binary installers for OSX do install all of the std library, and AFAIK the same is true for the version of python that ships with the OS.

Please explains how to reproduce the problem you are having:

* What release of OSX

* Which python version (/usr/bin/python, binary installer from www.python.org (and if so which one))?

* How can I verify that the problem is present?
msg172748 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-10-12 14:42
In current OS X releases, it is true that the system Pythons as shipped by Apple do not include the .py files in /System/Library/Frameworks/Python.framework; only .pyc and .pyo files are present.  However, those .py files are added when you install the "Command Line Tools" component of Xcode 4.  So, either do that or install another version of python, like from python.org.  In any case, the behavior is under the control of Apple and OS X, not Python.
msg172793 - (view) Author: Doug Ransom (Doug.Ransom) Date: 2012-10-13 00:37
The problem described was in respect to the python installed by the installer from python.org, not the python that ships with mac.  Using OSX 10.8.1.

Installing python from python.org binary installer does not fix the problem.  I ran the installer before submitting this bug, which is in reference to the installer downloaded from python.org, not what OSX Provides.  It may be that if OS X already installed python 2.7 the installer from python.org doesn't do anything. 

Installing Xcode Command Line tools also doesn't seem to work.

installing python from ports sudo port install python27 does seem to work.

Therefore, I think the problem is with the binary installer for os x.  I think this deserves closer inspection.
msg172794 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-10-13 00:51
There is *no* way to install Python using a python.org installer and *not* have the .py files installed.  You would have to go in and remove those files yourself.  You should be able to see the .py files yourself by looking at /Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7. Most likely the IDE you are using is not using the Python instance you think it is.  To use a python.org Python, it would likely need to be reconfigured to use /usr/local/bin/python2.7 or /Library/Frameworks/Python.framework/Versions/2.7/bin/python2.7.

If you still think there is a problem, please enumerate the steps you are performing and explain exactly what failure you are seeing.  Also, include the results of running the following in the failing configuration:

import sys
print(sys.executable)
print(sys.path)
print(sys.version)
msg172949 - (view) Author: Ronald Oussoren (ronaldoussoren) * (Python committer) Date: 2012-10-15 07:52
I'm closing this as invalid as the python sources for the stdlib are installed by the python.org installer, and this is probably a problem with PyDev.

It is lame that Apple doesn't install the python sources anymore, but there is nothing we can do about that.

Feel free to reopen when there is more information that points to a problem with python.
History
Date User Action Args
2012-10-15 07:52:04ronaldoussorensetstatus: open -> closed
resolution: not a bug
messages: + msg172949
2012-10-13 00:51:22ned.deilysetmessages: + msg172794
2012-10-13 00:37:17Doug.Ransomsetstatus: closed -> open
resolution: not a bug -> (no value)
messages: + msg172793
2012-10-12 14:42:29ned.deilysetstatus: open -> closed

nosy: + ned.deily
messages: + msg172748

resolution: not a bug
stage: resolved
2012-10-12 14:00:36ronaldoussorensetmessages: + msg172744
2012-10-12 13:54:55Doug.Ransomcreate