classification
Title: How to open a csv file in universal new line mode?
Type: Stage: resolved
Components: macOS Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: kason561, r.david.murray, ronaldoussoren
Priority: normal Keywords:

Created on 2012-09-29 17:31 by kason561, last changed 2012-09-29 17:41 by r.david.murray. This issue is now closed.

Messages (2)
msg171580 - (view) Author: Kason (kason561) Date: 2012-09-29 17:31
I am trying to follow the tutorial at http://www.slideshare.net/niloyghosh1984/qgis-tutorial-1
and I got to slide 24 of 47 whereupon I tried to use the mmqgis plugin to open the csv file, but I got this error:
Error: new-line character seen in unquoted field - do you need to open the file in universal-newline mode?
After searching for solutions to this error it indeed appears that I need to open this file in universal-newline mode...rU
How do I do that?
msg171582 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-09-29 17:41
The bug tracker isn't a good place to get help on using Python.  You are more likely to find people to answer this sort of question on the python-list mailing list.  If you are using python3, the answer is to use newline='', as discussed in the documentation.
History
Date User Action Args
2012-09-29 17:41:54r.david.murraysetstatus: open -> closed

type: compile error ->
assignee: ronaldoussoren ->

nosy: + r.david.murray
messages: + msg171582
resolution: not a bug
stage: resolved
2012-09-29 17:31:59kason561create