classification
Title: Sqlite3 performance
Type: performance Stage:
Components: Extension Modules Versions: Python 3.4
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Migrate sqlite3 module to _v2 API to enhance performance
View: 9303
Assigned To: Nosy List: jhlj, loewis, vstinner
Priority: normal Keywords:

Created on 2012-08-22 12:51 by jhlj, last changed 2012-08-22 14:57 by loewis. This issue is now closed.

Files
File name Uploaded Description Edit
db-test.py jhlj, 2012-08-22 12:51
Messages (3)
msg168881 - (view) Author: Jens Henrik Leonhard Jensen (jhlj) Date: 2012-08-22 12:51
The _sqlite modules uses sqlite3_prepare and not sqlite3_prepare_v2.
With sqlite3_prepare_v2 enables more optiomation.

Workaround:
Do not use parameters as the right hand argument to GLOB or LIKE.

For more documentation see http://www.sqlite.org/optoverview.html.
msg168886 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2012-08-22 14:15
Such change cannot be done in a version older than Python 3.4 (older versions only accept bugfixes, this is an improvment).
msg168890 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2012-08-22 14:57
This is a duplicate of #9303
History
Date User Action Args
2012-08-22 14:57:49loewissetstatus: open -> closed

nosy: + loewis
messages: + msg168890

superseder: Migrate sqlite3 module to _v2 API to enhance performance
resolution: duplicate
2012-08-22 14:15:59vstinnersetnosy: + vstinner

messages: + msg168886
versions: - Python 2.6, Python 3.1, Python 2.7, Python 3.2, Python 3.3
2012-08-22 12:51:11jhljcreate