classification
Title: Some numeric characters are still not recognized
Type: enhancement Stage: test needed
Components: Unicode Versions: Python 3.1, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: 1571184 Superseder:
Assigned To: lemburg Nosy List: andersch, belopolsky, ezio.melotti, lemburg
Priority: normal Keywords:

Created on 2006-10-05 07:31 by andersch, last changed 2010-12-09 08:56 by andersch. This issue is now closed.

Messages (5)
msg61013 - (view) Author: Anders Chrigström (andersch) Date: 2006-10-05 07:31
Looking into the documentation of the unicode database
i found that there are some numeric characters that are
not listed in the UnicodeData.txt file. They are intead
listen in the Unihan.txt file. (See
http://www.unicode.org/Public/5.0.0/ucd/UCD.html#Numeric_Type_Han).

I have a patch for this in the works.

msg61014 - (view) Author: Anders Chrigström (andersch) Date: 2006-10-05 08:05
Logged In: YES 
user_id=621306

I have uploaded patch #1571184 that fixes this.
msg61015 - (view) Author: Marc-Andre Lemburg (lemburg) * (Python committer) Date: 2006-10-05 10:44
Logged In: YES 
user_id=38388

For quick reference, here's the patch URL:

https://sourceforge.net/tracker/index.php?func=detail&aid=1571184&group_id=5470&atid=305470

I'll comment there.

It's really sad that the Unicode Consortium is separating
out all kinds of properties into separate files... makes
following the standard a lot harder.
msg123514 - (view) Author: Alexander Belopolsky (belopolsky) * (Python committer) Date: 2010-12-07 02:48
Is there anything in this issue that is not addressed by #1571184?  It looks like this was originally reported on SF where bug reports and patches had separate ids, so this is probably a duplicate of #1571184.
msg123674 - (view) Author: Anders Chrigström (andersch) Date: 2010-12-09 08:56
This is indeed a duplicate of #1571184
History
Date User Action Args
2010-12-09 08:56:39anderschsetstatus: open -> closed
resolution: duplicate
messages: + msg123674
2010-12-07 02:48:14belopolskysetnosy: + belopolsky
messages: + msg123514
2010-07-05 20:35:31ezio.melottisetnosy: + ezio.melotti
2009-03-30 02:04:52ajaksu2setdependencies: + Generate numeric/space/linebreak from Unicode database.
type: enhancement
stage: test needed
versions: + Python 3.1, Python 2.7
2006-10-05 07:31:51anderschcreate