classification
Title: PEP 3121, 384 Refactoring applied to testcapi module
Type: resource usage Stage: resolved
Components: Extension Modules Versions: Python 3.11
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Robin.Schreiber, asvetlov, erlendaasland, iritkatriel
Priority: normal Keywords: pep3121

Created on 2012-08-15 14:58 by Robin.Schreiber, last changed 2021-12-09 12:44 by erlendaasland. This issue is now closed.

Files
File name Uploaded Description Edit
_testcapi_pep3121-384_v0.patch Robin.Schreiber, 2012-08-15 14:58
Messages (3)
msg168305 - (view) Author: Robin Schreiber (Robin.Schreiber) * (Python triager) Date: 2012-08-15 14:58
Changes proposed in PEP3121 and PEP384 have now been applied to the testcapi module!
msg408027 - (view) Author: Irit Katriel (iritkatriel) * (Python committer) Date: 2021-12-08 15:31
The patch needs to be converted to a github PR.
msg408114 - (view) Author: Erlend E. Aasland (erlendaasland) * (Python triager) Date: 2021-12-09 12:44
The _testcapi modules should stay as it is, ref. msg384272 on bpo-40077:

    Yes, please keep _testcapimodule.c as it is. Static types are still supported and need to be tested.
History
Date User Action Args
2021-12-09 12:44:06erlendaaslandsetstatus: open -> closed

nosy: + erlendaasland
messages: + msg408114

resolution: not a bug
stage: resolved
2021-12-08 15:31:40iritkatrielsetnosy: + iritkatriel

messages: + msg408027
versions: + Python 3.11, - Python 3.4
2012-11-08 13:35:51Robin.Schreibersetkeywords: + pep3121, - patch
2012-08-27 03:42:36belopolskylinkissue15787 dependencies
2012-08-17 16:41:41asvetlovsetnosy: + asvetlov
2012-08-15 14:58:29Robin.Schreibercreate