classification
Title: Tru64 make install failure
Type: behavior Stage: resolved
Components: Installation Versions: Python 3.0, Python 2.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: anthonybaxter Nosy List: ajaksu2, anthonybaxter, chris_laws, nnorwitz, rwgk
Priority: low Keywords:

Created on 2006-09-14 17:51 by rwgk, last changed 2009-04-25 21:39 by ajaksu2. This issue is now closed.

Messages (6)
msg29821 - (view) Author: Ralf W. Grosse-Kunstleve (rwgk) Date: 2006-09-14 17:51
"make install" of Python 2.5c2 fails under Tru64 Unix
V5.1. The failure is fixed by the simple patch below.
I.e., simply remove two lines from Makefile.pre.in.
Apparently the native make doesn't support comments
where commands are expected.


diff -r -u Python-2.5c2/Makefile.pre.in
Python-2.5c2_cci/Makefile.pre.in
--- Python-2.5c2/Makefile.pre.in        2006-07-30
09:20:10.000000000 -0700
+++ Python-2.5c2_cci/Makefile.pre.in    2006-09-14
10:17:12.000000000 -0700
@@ -850,8 +850,6 @@
        $(INSTALL_DATA) Modules/Setup.config
$(DESTDIR)$(LIBPL)/Setup.config
        $(INSTALL_SCRIPT) $(srcdir)/Modules/makesetup
$(DESTDIR)$(LIBPL)/makesetup
        $(INSTALL_SCRIPT) $(srcdir)/install-sh
$(DESTDIR)$(LIBPL)/install-sh
-       # Substitution happens here, as the
completely-expanded BINDIR
-       # is not available in configure
        sed -e
"s,@EXENAME@,$(BINDIR)/python$(VERSION)$(EXE)," <
$(srcdir)/Misc/python-config.in >python-config
        $(INSTALL_SCRIPT) python-config
$(DESTDIR)$(BINDIR)/python$(VERSION)-config
        rm python-config
msg29822 - (view) Author: Neal Norwitz (nnorwitz) * (Python committer) Date: 2006-09-15 04:30
Logged In: YES 
user_id=33168

Assigning to Anthony so he sees this.
msg29823 - (view) Author: chris_laws (chris_laws) Date: 2007-08-13 04:48
Not sure if this is appropriate here but it may at least indicate that the issue is affecting more than one user. I've just come across this bug and implementing the suggested patch fixed the issue for me. 
My company has a lot of DEC Alpha's (uname -a: OSF1 <hostname> V4.0 1530 alpha) that we want to run Python on. It would be great if this simple fix was rolled into the main baseline in a future release.
msg84473 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-03-30 03:08
Ralf, Chris, is this still an issue?

Feedback from issue 727732 makes me believe this is a pretty ancient
platform, so I'll close this if no interested parties voice their
opposition.
msg84521 - (view) Author: Ralf W. Grosse-Kunstleve (rwgk) Date: 2009-03-30 06:54
It is no longer a problem for me. As of last fall, we don't have any
Tru64 machines anymore.
msg86557 - (view) Author: Daniel Diniz (ajaksu2) (Python triager) Date: 2009-04-25 21:39
Thanks for the feedback, Ralf.
History
Date User Action Args
2009-04-25 21:39:40ajaksu2setstatus: pending -> closed
resolution: out of date
messages: + msg86557

stage: test needed -> resolved
2009-03-30 06:54:53rwgksetmessages: + msg84521
2009-03-30 03:08:27ajaksu2setstatus: open -> pending
priority: normal -> low
type: behavior

versions: + Python 2.6, Python 3.0, - Python 2.5
nosy: + ajaksu2

messages: + msg84473
stage: test needed
2006-09-14 17:51:12rwgkcreate