classification
Title: tools and demo missing from windows
Type: Stage:
Components: Build Versions: Python 2.5
process
Status: closed Resolution: wont fix
Dependencies: Superseder:
Assigned To: Nosy List: jimjjewett, loewis
Priority: normal Keywords:

Created on 2006-08-16 16:19 by jimjjewett, last changed 2007-10-10 06:12 by loewis. This issue is now closed.

Messages (3)
msg29522 - (view) Author: Jim Jewett (jimjjewett) Date: 2006-08-16 16:19
The windows distribution (I'm currently looking at 
2.5b3) does not contain a Demo directory, and the 
Tools directory contains only five subdirectories 
(i18n, pynche, Scripts, versioncheck, webchecker)

SVN Head lists 20 directories under Demo and 17 under 
Tools.

At a first pass, all except tools/audiopy (Solaris 
specific) are relevant on Windows, and some tools 
(such as freeze, msi) even have windows-specific code.

I've marked it 2.5 because consistency with other 
platforms seems like a bugfix, even if it does 
introduce new features to windows.  (And note that it 
only adds new files that are not on the standard path, 
which should limit the risks.)
msg29523 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2006-08-18 07:04
Logged In: YES 
user_id=21627

This must wait until 2.5.1; more likely 2.6.

The Windows distribution was structured that way always, so
it's not a regression.

"Consistency with other platforms" is not a valid argument:
there are no binary distributions for other platforms except
for OSX (whether that includes Tools or Demo, I don't know).
The source distribution for Windows is the very same as the
source distribution for other platforms, and it does include
Tools and Demo, so it's (trivially) consistent.

I don't think the Demo directory should be included. The
equivalent of a binary distribution on Unix (make install)
doesn't install the Demos, either.

As for the Tools directory: this traditionally includes
directories on a per-request basis. If there is an actual
need for another tool, it should be added.
msg56310 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2007-10-10 06:12
I'm closing it as "won't fix". If you have specific tools that you would
like to see included, please submit that as a separate report, along
with a rationale as to why you want to see them included.
History
Date User Action Args
2007-10-10 06:12:47loewissetstatus: open -> closed
resolution: wont fix
messages: + msg56310
2006-08-16 16:19:53jimjjewettcreate