classification
Title: Uparrow doesn't show previously typed variable or character
Type: behavior Stage: resolved
Components: Interpreter Core Versions: Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Tyler.Crompton, kracekumar, ned.deily
Priority: normal Keywords:

Created on 2012-06-27 17:33 by kracekumar, last changed 2012-06-27 19:54 by r.david.murray. This issue is now closed.

Messages (3)
msg164175 - (view) Author: Kracekumar Ramaraj (kracekumar) Date: 2012-06-27 17:33
Below is the copy & paste from the Interpreter.

kracekumar@python-lover:~/codes/python/Python-3.3.0b1$ python3.3
Python 3.3.0b1 (default, Jun 27 2012, 22:27:38) 
[GCC 4.6.3] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> __builtins__
<module 'builtins'>
>>> ^[[A^[[A 

On pressing the up arrow inside 3.3 b1 interpreter doesn't show previously typed variable or statement.

This test was carried out in ubuntu 12.04.
msg164178 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-06-27 17:55
It looks like the Python you are using was built without GNU readline.  You probably need to install the libreadline-dev package from Ubuntu and rebuild Python.
msg164193 - (view) Author: Tyler Crompton (Tyler.Crompton) Date: 2012-06-27 19:53
I recreated this issue on (mostly) fresh install of Ubuntu Server 12.04. I installed libreadline-dev and then removed and re-installed Python 3.3.0b1. This resolved the issue.
History
Date User Action Args
2012-06-27 19:54:16r.david.murraysetstatus: open -> closed
stage: resolved
2012-06-27 19:53:16Tyler.Cromptonsetstatus: pending -> open
nosy: + Tyler.Crompton
messages: + msg164193

2012-06-27 17:55:12ned.deilysetstatus: open -> pending

nosy: + ned.deily
messages: + msg164178

resolution: not a bug
2012-06-27 17:33:03kracekumarcreate