classification
Title: Allow whitespace and comments after line continuation character \
Type: enhancement Stage:
Components: Interpreter Core Versions: Python 3.4
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Ztatik.Light, eric.smith, mark.dickinson
Priority: normal Keywords:

Created on 2012-06-26 08:22 by Ztatik.Light, last changed 2012-06-26 08:59 by eric.smith. This issue is now closed.

Messages (3)
msg164055 - (view) Author: Ztatik Light (Ztatik.Light) Date: 2012-06-26 08:22
See Title
msg164059 - (view) Author: Mark Dickinson (mark.dickinson) * (Python committer) Date: 2012-06-26 08:57
I think a change at this level should be discussed on the python-ideas mailing list: http://mail.python.org/mailman/listinfo/python-ideas .  Ztatik, please can you post there?  It would help to include some motivation for the change in your posting;  if you have a working patch, that would also be useful.
msg164060 - (view) Author: Eric V. Smith (eric.smith) * (Python committer) Date: 2012-06-26 08:59
This would be a big change. Please bring it up on the python-ideas mailing list for discussion first. If it is approved there, we can re-open this issue.

You'll need to present your use-case: Why this would be an improvement to Python? What would it allow you to do that you can't do now?
History
Date User Action Args
2012-06-26 08:59:12eric.smithsetstatus: open -> closed

nosy: + eric.smith
messages: + msg164060

resolution: not a bug
2012-06-26 08:57:35mark.dickinsonsetnosy: + mark.dickinson

messages: + msg164059
versions: + Python 3.4, - 3rd party
2012-06-26 08:23:24Ztatik.Lightsettitle: Allow whitespace and comments after line line continuation character \ -> Allow whitespace and comments after line continuation character \
2012-06-26 08:22:24Ztatik.Lightcreate