classification
Title: Changes to PyMethod_New breaks ctypes on Windows
Type: Stage:
Components: Extension Modules, Windows Versions: Python 3.0
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: theller Nosy List: christian.heimes, theller
Priority: high Keywords:

Created on 2007-11-27 13:02 by christian.heimes, last changed 2008-01-06 22:29 by admin. This issue is now closed.

Messages (3)
msg57871 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-27 13:02
The problem is in _ctypes.c:create_comerror() around line 4620.
msg57881 - (view) Author: Thomas Heller (theller) * (Python committer) Date: 2007-11-27 19:16
Christian Heimes schrieb:
> > New submission from Christian Heimes:
> > 
> > The problem is in _ctypes.c:create_comerror() around line 4620.

The code tries to populate a dict with methods and finally pass them to
   PyErr_NewException("_ctypes.COMError", NULL, dict);

I have no idea what to do.  What do I have to put into the dict?
msg57912 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-28 13:43
The removal of unbound methods made it hard to bind CFunctions. I
rewrote the code in r59215.
History
Date User Action Args
2008-01-06 22:29:44adminsetkeywords: - py3k
versions: Python 3.0
2007-11-28 13:43:48christian.heimessetstatus: open -> closed
resolution: fixed
messages: + msg57912
2007-11-27 19:16:43thellersetmessages: + msg57881
2007-11-27 13:02:37christian.heimescreate