classification
Title: PCBuild9 _ssl.vcproj improperly launches build
Type: compile error Stage:
Components: Windows Versions: Python 3.0, Python 2.6
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: christian.heimes Nosy List: JosephArmbruster, christian.heimes
Priority: normal Keywords: patch

Created on 2007-11-22 18:41 by JosephArmbruster, last changed 2008-01-06 22:29 by admin. This issue is now closed.

Files
File name Uploaded Description Edit
sslbuild.patch JosephArmbruster, 2007-11-22 18:41
Messages (6)
msg57763 - (view) Author: Joseph Armbruster (JosephArmbruster) Date: 2007-11-22 18:41
When you attempt to build the _ssl project in release or debug you can
possibly encounter errors in the following scenarios:

1) having spaces in the build path

2) if you launch the build in debug, it attempts to run build_ssl.py
with the python.exe found in the path rather than that just built named
python_d.exe.  I believe the solution was designed to run build_ssl.py
with the binary that was built in the configuration.  If this is
correct, then this patch applies.

3) some of the dependency paths did not appear to point to the correct
place.  Please verify.

See attached patch
msg57764 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-22 18:48
Thanks, I'll check it later.
msg57770 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-23 07:06
I've fixed (1) and (2) in r59130. I don't understand what you mean with (3).
msg57785 - (view) Author: Joseph Armbruster (JosephArmbruster) Date: 2007-11-23 13:14
Looks like the libpaths were pointing to out32 instead of out32.dll. 
Although that may have been due to my switch from nt.mak to ntdll.mak.
msg57786 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2007-11-23 13:51
out32 is the correct directory. The windows version of Python is
statically linked against the SSL libs. We don't want to ship yet
another DLL.
msg57790 - (view) Author: Joseph Armbruster (JosephArmbruster) Date: 2007-11-23 16:31
Whoops.  This may have been an error on my part.  nt.mak I think bombed
for me except it was probably due to some of my tinkering.  My apologies.
History
Date User Action Args
2008-01-06 22:29:44adminsetkeywords: - py3k
versions: Python 2.6, Python 3.0
2007-11-23 16:31:23JosephArmbrustersetmessages: + msg57790
2007-11-23 14:05:20christian.heimessetstatus: pending -> closed
2007-11-23 13:51:51christian.heimessetmessages: + msg57786
2007-11-23 13:14:26JosephArmbrustersetmessages: + msg57785
2007-11-23 07:06:41christian.heimessetstatus: open -> pending
resolution: fixed
messages: + msg57770
2007-11-22 18:48:57christian.heimessetpriority: normal
assignee: christian.heimes
messages: + msg57764
keywords: + py3k, patch
versions: + Python 2.6
2007-11-22 18:41:50JosephArmbrustercreate