classification
Title: Idle tab command completion
Type: behavior Stage:
Components: IDLE Versions: Python 2.5
process
Status: closed Resolution: rejected
Dependencies: Superseder:
Assigned To: Nosy List: Mufasa, facundobatista, quentin.gallet-gilles
Priority: normal Keywords:

Created on 2007-11-22 13:02 by Mufasa, last changed 2007-11-23 17:10 by facundobatista. This issue is now closed.

Messages (5)
msg57759 - (view) Author: Grant Delaney (Mufasa) Date: 2007-11-22 13:02
Running idle from a terminal window in desktop. 

Python 2.5.1 (r251:54863, Nov 22 2007, 13:55:16) 
[GCC 4.1.2] on linux2
Type "copyright", "credits" or "license()" for more information.

    ****************************************************************
    Personal firewall software may warn about the connection IDLE
    makes to its subprocess using this computer's internal loopback
    interface.  This connection is not visible on any external
    interface and no data is sent to or received from the Internet.
    ****************************************************************
    
IDLE 1.2.1      
>>> import sys
>>> test = sys.    <--- pressing tab should give you the available
options for that module/library.

The error in the console is as follows:

Exception in Tkinter callback
Traceback (most recent call last):
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 1403, in __call__
    return self.func(*args)
  File "/usr/lib/python2.5/idlelib/AutoCompleteWindow.py", line 217, in
winconfig_event
    x, y, cx, cy = self.widget.bbox(self.startindex)
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 2833, in bbox
    self.tk.call((self._w, 'bbox') + args)) or None
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 1030, in _getints
    return tuple(map(getint, self.tk.splitlist(string)))
ValueError: invalid literal for int() with base 10: '(128,'
Exception in Tkinter callback
Traceback (most recent call last):
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 1403, in __call__
    return self.func(*args)
  File "/usr/lib/python2.5/idlelib/AutoCompleteWindow.py", line 217, in
winconfig_event
    x, y, cx, cy = self.widget.bbox(self.startindex)
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 2833, in bbox
    self.tk.call((self._w, 'bbox') + args)) or None
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 1030, in _getints
    return tuple(map(getint, self.tk.splitlist(string)))
ValueError: invalid literal for int() with base 10: '(128,'
Exception in Tkinter callback
Traceback (most recent call last):
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 1403, in __call__
    return self.func(*args)
  File "/usr/lib/python2.5/idlelib/AutoCompleteWindow.py", line 217, in
winconfig_event
    x, y, cx, cy = self.widget.bbox(self.startindex)
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 2833, in bbox
    self.tk.call((self._w, 'bbox') + args)) or None
  File "/usr/lib/python2.5/lib-tk/Tkinter.py", line 1030, in _getints
    return tuple(map(getint, self.tk.splitlist(string)))
ValueError: invalid literal for int() with base 10: '(128,'
msg57760 - (view) Author: Facundo Batista (facundobatista) * (Python committer) Date: 2007-11-22 13:06
On IDLE and Python with the same exact version, but in Windows, this
works ok.

Don't have IDLE in Linux to try it, though.
msg57766 - (view) Author: Quentin Gallet-Gilles (quentin.gallet-gilles) Date: 2007-11-22 20:14
Couldn't reproduce it either, with the following IDLE config:

Python 2.5.1 (r251:54863, Oct  5 2007, 13:36:32) 
[GCC 4.1.3 20070929 (prerelease) (Ubuntu 4.1.2-16ubuntu2)] on linux2
IDLE 1.2.1      ==== No Subprocess ====
msg57791 - (view) Author: Grant Delaney (Mufasa) Date: 2007-11-23 16:59
You can remove this issue. It was a compile problem on my side, missing
libs etc.
msg57793 - (view) Author: Facundo Batista (facundobatista) * (Python committer) Date: 2007-11-23 17:10
Rejected as requested by the OP.
History
Date User Action Args
2007-11-23 17:10:56facundobatistasetstatus: open -> closed
resolution: rejected
messages: + msg57793
2007-11-23 16:59:11Mufasasetmessages: + msg57791
2007-11-22 20:14:30quentin.gallet-gillessetnosy: + quentin.gallet-gilles
messages: + msg57766
2007-11-22 13:06:04facundobatistasetnosy: + facundobatista
messages: + msg57760
2007-11-22 13:02:56Mufasacreate