classification
Title: Non-admin installation fails
Type: behavior Stage: resolved
Components: Installation, Windows Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Windows Installer won't - even when using "just for me"option
View: 22516
Assigned To: Nosy List: Cesar.Mello, brian.curtin, bwanamarko, loewis, r.david.murray, steve.dower, tim.golden, toughy, zach.ware
Priority: normal Keywords:

Created on 2012-03-31 12:57 by toughy, last changed 2015-07-04 04:37 by bwanamarko. This issue is now closed.

Files
File name Uploaded Description Edit
install-3.2.2-x64.log toughy, 2012-03-31 12:57 msiexec install log
Install-admin-msg.png toughy, 2012-03-31 12:58 Install error message box
Messages (8)
msg157183 - (view) Author: Timothy Madden (toughy) Date: 2012-03-31 12:57
Trying to install the release package (python 3.2.2 x86-64 .msi, 2.7.2 x86-64 .msi) without elevation fails, even if 'Install just for me' is selected in the installer options, and I have write permissions in the selected install folder.

Under the same account and conditions, other installers (Mozilla Firefox/Thunderbird, git, Beaver Debugger...) can install successfully.

Here the msiexec log file is attached, created with:
    msiexec /package C:\Users\belladrianc\Downloads\python-3.2.2.amd64.msi /l*v install-3.2.2-x64.log
msg157184 - (view) Author: Timothy Madden (toughy) Date: 2012-03-31 12:58
attaching the error message box
msg157185 - (view) Author: Timothy Madden (toughy) Date: 2012-03-31 13:07
This is happening on Windows Server 2008 R2 Enterprise, Service Pack 1 (64-bit)
msg165423 - (view) Author: Cesar Mello (Cesar.Mello) Date: 2012-07-13 21:07
Just as a note: the following command line with /q instead of /qb works without the need for elevation:

msiexec /q /i python-2.7.3.amd64.msi MSIFASTINSTALL=7 TARGETDIR=C:\Users\Mello\Python27

And it is pretty fast! This was on a Windows 7 machine.

But if I install in a clean Windows XP, I can't get it to work. It seems something is not right with the CRT using this command line.
msg165750 - (view) Author: Timothy Madden (toughy) Date: 2012-07-18 10:09
The command also worked for me on Windows 7 Professional 64-bit, but pythonw does not start, and I could not check if everything in CLI python.exe works as expected.

As you said, something is not right with it, and it also installs just too fast for a real installation.

It did get my python installed, though. Thank you for the info, you must have played with it quite a while
msg240560 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2015-04-12 15:56
Is this a duplicate of issue 22516?
msg240561 - (view) Author: Zachary Ware (zach.ware) * (Python committer) Date: 2015-04-12 15:57
Pretty much.
msg246239 - (view) Author: Mark Mikofski (bwanamarko) Date: 2015-07-04 04:37
Anyone still following this issue, as I posted in issue22516, there is an embeddable zipped version of Python-2.7.X built from source using the PCbuild batch files and vc90 toolset for both x86 and x64 called Python Bootstrap:

http://breakingbytes.alwaysdata.net/PythonBootstrap/

The redistributable msvcr90.dll's are all bundled side-by-side privately with python27.dll as recommended by Windows and does not violate any licensing eulas. The build passes all tests and pythonw.exe works perfectly. Try starting python27/Scripts/idle.bat.

It ...
just ...
works ...

No ...
Admin ...
rights ...
required ...

just ...
unzip ...
use ...

FYI: doing an "administrative install" using msiexec /a (https://www.python.org/download/releases/2.4/msi/) just extracts the msi archive and creates a smaller msi package used to do a local install later. This means that your python launcher and shared library are depending on whatever redistributables you have. You can't install the merge modules into winsxs w/o elevated rights so ...

Also look at Python-3.5 for an embeddable zip file (no admin rights required) altho I think it requires vcredist for vc100 freely available from microsoft.
History
Date User Action Args
2015-07-04 04:37:46bwanamarkosetnosy: + bwanamarko
messages: + msg246239
2015-04-12 15:57:57zach.waresetstatus: open -> closed
superseder: Windows Installer won't - even when using "just for me"option
messages: + msg240561

resolution: duplicate
stage: resolved
2015-04-12 15:56:10r.david.murraysetnosy: + r.david.murray, tim.golden, zach.ware, steve.dower
messages: + msg240560
components: + Windows
2012-07-18 10:09:58toughysetmessages: + msg165750
2012-07-13 23:25:05pitrousetnosy: + loewis
2012-07-13 21:07:21Cesar.Mellosetnosy: + Cesar.Mello
messages: + msg165423
2012-03-31 15:35:22r.david.murraysetnosy: + brian.curtin
2012-03-31 13:07:11toughysetmessages: + msg157185
2012-03-31 12:58:34toughysetfiles: + Install-admin-msg.png

messages: + msg157184
2012-03-31 12:57:30toughycreate