classification
Title: add a note regarding building on recent versions of Debian and Ubuntu
Type: enhancement Stage: resolved
Components: Devguide Versions: Python 3.3
process
Status: closed Resolution: duplicate
Dependencies: Superseder: devguide doesn’t list all build dependencies
View: 13472
Assigned To: Nosy List: barry, eric.araujo, ezio.melotti, pitrou, tshepang
Priority: normal Keywords: patch

Created on 2012-02-06 20:46 by tshepang, last changed 2012-02-08 17:08 by eric.araujo. This issue is now closed.

Files
File name Uploaded Description Edit
note-on-building-on-recent-debian-releases.patch tshepang, 2012-02-06 20:46
Messages (8)
msg152773 - (view) Author: Tshepang Lekhonkhobe (tshepang) * Date: 2012-02-06 20:46
I was puzzled why the various parts, like readline and ssl, failed to be built into my Python. It was after seeing #11715 that I realized I needed to install dpkg-dev, whose binary, dpkg-architecture, helps detect the locations of those libraries ().
msg152851 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-02-08 12:53
Or, rather, setup.py should be smart enough to warn about that.
msg152867 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2012-02-08 15:19
On Feb 08, 2012, at 12:53 PM, Antoine Pitrou wrote:

>Or, rather, setup.py should be smart enough to warn about that.

It shouldn't just be limited to Debian and its derivatives.  Other platforms
(even Linux OSes) will probably have similar issues.
msg152870 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2012-02-08 15:37
> >Or, rather, setup.py should be smart enough to warn about that.
> 
> It shouldn't just be limited to Debian and its derivatives.  Other platforms
> (even Linux OSes) will probably have similar issues.

The issue (having to install dpkg-dev) is specifically about Debian and
Ubuntu. I don't think we should have tons of platform-specific
instructions in the devguide, and I think that in this case setup.py
should detect that the required tool is missing (depending on the
platform, of course).
msg152872 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2012-02-08 15:51
The correct way to get build dependencies on Debian and derivatives is to use “aptitude build-dep pythonX.Y” (see #13472).  I think dpkg-dev would get installed as a dependency; Tshepang, could you uninstall dpkg-dev and test the aptitude command?
msg152874 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2012-02-08 15:55
On Feb 08, 2012, at 03:51 PM, Éric Araujo wrote:

>The correct way to get build dependencies on Debian and derivatives is to use
>“aptitude build-dep pythonX.Y” (see #13472).  I think dpkg-dev would get
>installed as a dependency; Tshepang, could you uninstall dpkg-dev and test
>the aptitude command?

+1 and that definitely works.  I use that all the time on new VMs.

If it *doesn't* work, then that's a bug in the Debian pythonX.Y package.
msg152875 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2012-02-08 15:57
Then I propose to close this as duplicate of #13472.
msg152878 - (view) Author: Tshepang Lekhonkhobe (tshepang) * Date: 2012-02-08 16:07
@Barry, it does work on Debian as well
@Eric, I agree with closing it as a dupe
History
Date User Action Args
2012-02-08 17:08:07eric.araujosetstatus: open -> closed
resolution: duplicate
superseder: devguide doesn’t list all build dependencies
stage: resolved
2012-02-08 16:07:19tshepangsetmessages: + msg152878
2012-02-08 15:57:37eric.araujosetmessages: + msg152875
2012-02-08 15:55:40barrysetmessages: + msg152874
2012-02-08 15:51:03eric.araujosetnosy: + eric.araujo
messages: + msg152872
2012-02-08 15:37:09pitrousetmessages: + msg152870
2012-02-08 15:19:36barrysetmessages: + msg152867
2012-02-08 12:53:54pitrousetnosy: + barry, pitrou
messages: + msg152851
2012-02-06 20:46:37tshepangcreate