classification
Title: Adds the .compact() method to bsddb db.DB objects
Type: enhancement Stage:
Components: Extension Modules Versions: Python 2.6
process
Status: closed Resolution: accepted
Dependencies: Superseder:
Assigned To: jcea Nosy List: donmez, gregory.p.smith, jcea
Priority: normal Keywords: patch

Created on 2007-11-05 01:49 by gregory.p.smith, last changed 2009-01-21 15:17 by jcea. This issue is now closed.

Files
File name Uploaded Description Edit
add-bsddb-db_compact-gps01.patch.txt gregory.p.smith, 2007-11-05 01:49
Messages (5)
msg57116 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2007-11-05 01:49
I'm attaching the patch to add this method here just as a place to track
it for now.  It compiles and it looks right, but it causes a crash
within BerkeleyDB when the test case runs using BerkeleyDB 4.6.21.  It
passes as expected when using 4.4.20 or 4.5.20.

I won't commit this until the 4.6 crash issue is resolved.

python bindings for the compact method were requested here:

http://sourceforge.net/tracker/index.php?func=detail&aid=1724985&group_id=13900&atid=363900
msg61830 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2008-01-29 21:35
I can reproduce the crash from a pure C program, so this library seems
buggy. Posting a report in
http://forums.oracle.com/forums/thread.jspa?threadID=611821
msg61892 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2008-01-31 10:03
Oracle confirms the issue. They will provide a patch.
msg66981 - (view) Author: Gregory P. Smith (gregory.p.smith) * (Python committer) Date: 2008-05-17 07:01
Jesus is the bsddb maintainer now.
msg80327 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2009-01-21 15:17
I committed this patch to the imminent pybsddb 4.6.4. This will be
available soon in http://www.jcea.es/programacion/pybsddb.htm, and in
future Python 2.7.

The function is only available if you are using Berkeley DB 4.7 or
newer, since 4.6 was very buggy.
History
Date User Action Args
2009-01-21 15:17:52jceasetstatus: open -> closed
resolution: accepted
messages: + msg80327
2008-05-17 07:01:58gregory.p.smithsetassignee: gregory.p.smith -> jcea
messages: + msg66981
2008-02-05 14:07:15donmezsetnosy: + donmez
2008-01-31 10:03:54jceasetmessages: + msg61892
2008-01-30 09:54:34christian.heimessetpriority: normal
2008-01-29 21:35:30jceasetmessages: + msg61830
2008-01-29 17:41:18jceasetnosy: + jcea
2007-11-25 00:27:37georg.brandlsetkeywords: - rfe
type: enhancement
2007-11-05 01:49:58gregory.p.smithcreate