classification
Title: Documentation of os.fdopen() refers to non-existing bufsize argument of builtin open()
Type: Stage:
Components: Documentation Versions: Python 3.2, Python 3.3
process
Status: closed Resolution: not a bug
Dependencies: Superseder: Update docs of os.fdopen()
View: 14863
Assigned To: docs@python Nosy List: docs@python, eric.araujo, petri.lehtinen
Priority: normal Keywords:

Created on 2011-12-30 11:36 by petri.lehtinen, last changed 2012-05-20 11:01 by petri.lehtinen. This issue is now closed.

Messages (2)
msg150376 - (view) Author: Petri Lehtinen (petri.lehtinen) * (Python committer) Date: 2011-12-30 11:36
From the docs of os.fdopen():

    Return an open file object connected to the file descriptor fd. The
    mode and bufsize arguments have the same meaning as the corresponding
    arguments to the built-in open() function.

However, there's no bufsize argument for builtin open() anymore in py3k.
msg161199 - (view) Author: Petri Lehtinen (petri.lehtinen) * (Python committer) Date: 2012-05-20 11:01
The documentation of os.fdopen() should be fixed as a whole, see #14863.
History
Date User Action Args
2012-05-20 11:01:13petri.lehtinensetstatus: open -> closed
superseder: Update docs of os.fdopen()
resolution: not a bug
messages: + msg161199
2012-01-09 16:01:38eric.araujosetnosy: + eric.araujo
2011-12-30 11:36:07petri.lehtinencreate