classification
Title: please close: hashlib uses OpenSSL which is much slower than Aaron Gifford
Type: resource usage Stage:
Components: Extension Modules Versions: Python 2.5
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Omnifarious, facundobatista
Priority: normal Keywords:

Created on 2007-10-30 00:56 by Omnifarious, last changed 2007-10-30 02:16 by facundobatista. This issue is now closed.

Messages (3)
msg56946 - (view) Author: Eric Hopper (Omnifarious) Date: 2007-10-30 00:56
Aaron Gifford's implementation of SHA-{256,384,512} is nearly twice as
fast as OpenSSLs.
msg56949 - (view) Author: Eric Hopper (Omnifarious) Date: 2007-10-30 01:33
My testing methodology was faulty, this is not actually true.  Oops.
msg56951 - (view) Author: Facundo Batista (facundobatista) * (Python committer) Date: 2007-10-30 02:16
The OP changed his mind, :)
History
Date User Action Args
2007-10-30 02:16:25facundobatistasetstatus: open -> closed
resolution: not a bug
messages: + msg56951
nosy: + facundobatista
2007-10-30 01:34:47Omnifarioussettitle: hashlib uses OpenSSL which is much slower than Aaron Gifford -> please close: hashlib uses OpenSSL which is much slower than Aaron Gifford
2007-10-30 01:33:49Omnifarioussetmessages: + msg56949
2007-10-30 00:56:13Omnifariouscreate