classification
Title: subprocess: undocumented if shell=True is necessary to find executable in Windows PATH
Type: Stage: resolved
Components: Documentation Versions:
process
Status: closed Resolution: duplicate
Dependencies: Superseder: subprocess PATH semantics and portability
View: 8557
Assigned To: docs@python Nosy List: Arfrever, docs@python, martin.panter, rosslagerwall, techtonik, vstinner
Priority: normal Keywords:

Created on 2011-10-17 11:27 by techtonik, last changed 2017-02-04 07:48 by martin.panter. This issue is now closed.

Messages (5)
msg145664 - (view) Author: anatoly techtonik (techtonik) Date: 2011-10-17 11:27
The reason I ask is this changeset - http://code.google.com/p/spyderlib/source/detail?spec=svne5d86b685619a470d593aa5f9ee360ba60779bc1&r=323c6c697f045166e384cdc15803d40eebed0a2b - seems like without shell=True, subprocess.Popen is unable to find Mercurial executable in PATH.
msg145665 - (view) Author: anatoly techtonik (techtonik) Date: 2011-10-17 11:30
Tracker is buggy - proper link to the changeset - http://bit.ly/qT1o4g
msg145666 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2011-10-17 11:32
Can't you merge this issue with #13195?
msg145673 - (view) Author: anatoly techtonik (techtonik) Date: 2011-10-17 11:50
Although they both touch the same components, they are completely different user stories.
msg286924 - (view) Author: Martin Panter (martin.panter) * (Python committer) Date: 2017-02-04 07:48
It is hard to make sense of this without decoding your URLs, downloading the repository and finding the relevant commit. Anyway, what you have posted sounds like a duplicate of Issue 8557.
History
Date User Action Args
2017-02-04 07:48:01martin.pantersetstatus: open -> closed

superseder: subprocess PATH semantics and portability

nosy: + martin.panter
messages: + msg286924
resolution: duplicate
stage: resolved
2011-10-17 14:01:18Arfreversetnosy: + Arfrever
2011-10-17 12:12:30rosslagerwallsetnosy: + rosslagerwall
2011-10-17 11:50:46techtoniksetmessages: + msg145673
2011-10-17 11:32:17vstinnersetnosy: + vstinner
messages: + msg145666
2011-10-17 11:30:50techtoniksetmessages: + msg145665
2011-10-17 11:27:21techtonikcreate