classification
Title: Module Doc viewer closes when browser window closes on Windows 8
Type: behavior Stage:
Components: Documentation, Windows Versions: Python 3.3
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: docs@python Nosy List: BreamoreBoy, docs@python, georg.brandl, mhammond, ncoghlan
Priority: normal Keywords:

Created on 2011-10-04 18:36 by brian.curtin, last changed 2014-10-06 14:40 by georg.brandl. This issue is now closed.

Messages (7)
msg144918 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-10-04 18:36
Reported by Ryan Wells (v-rywel@microsoft.com) of Microsoft, in reference to a problem with the Module Doc viewer on Windows 8 when using Internet Explorer 10. This was reported on 3.2.2, but it's likely the same on 2.7.


Reference #: 70652
Description of the Problem: The application Python Module Doc is automatically closed when Internet Explorer 10 is closed.
Steps to Reproduce:
1.       Install Windows Developer Preview
2.       Install Python 3.2.2
3.       Launch Module Doc.  Start Menu -> All Program -> Python -> Manual Docs
4.       Click on the button open browser
5.       It should open the site http://localhost:7464/ In Internet Explorer 10 and the contents should be displayed
6.       Should be able to view list of Modules, Scripts, DLLs, and Libraries etc.
7.       Close Internet Explorer

Expected Result: Internet Explorer 10 should only get closed and we should be able to work with the application Module Doc.
Actual Result: The application Module Doc is closed with Internet Explorer 10.
 
Developer Notes: There is likely a difference in return values between IE8 and IE9/10 when launched from the app.
msg144921 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2011-10-04 18:56
If that's the app I think it is (pydoc -g), we're probably going to kill it off in 3.3 in favour of the -b option.
msg144922 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2011-10-04 19:01
Slight correction, pydoc.gui() is already gone in current hg tip.

However, this error may be indicative of an underlying problem with webbrowser.open(url) throwing an exception.
msg144923 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-10-04 19:04
The menu shortcut opens up the following: "C:\Python32\pythonw.exe" "C:\Python32\Tools\scripts\pydocgui.pyw", which is just pydoc.gui()
msg144933 - (view) Author: Mark Hammond (mhammond) * (Python committer) Date: 2011-10-05 00:50
For some reason, IE is struggling to even display the page - it just seems to sit there loading the page without displaying anything, but hitting "stop" then "refresh" usually brings it up.  But if you kill IE (which best I can tell can only be done via the task manager - it has no other Windows controls) the doc server process does also terminate.

If you run the doc server using python.exe, you will notice tracebacks in the console due to the socket connection being reset (which is probably related to the above problems - the socket should have been fully read by the time you manage to kill IE) - but using python.exe the process stays alive serving requests.  I *guess* that the problem is pythonw.exe is hitting an error when it attempts to print to the invalid stderr handle.  It might be possible that somehow under Windows 8, stderr isn't buffered (or has as large of a buffer) as other Windows versions, so dies when a small amount of data is written to stderr - but I suspect the same problem could be provoked on other Windows versions by arranging for > 8k of "connection reset by peer" tracebacks to be written, at which point the buffer is attempted to be flushed and fails.

Here endeth my speculation for the day ;)
msg220207 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2014-06-10 22:57
This works fine for me with Windows 7, Python 3.4.1 and Firefox 29.
msg228699 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2014-10-06 14:40
pydoc.gui() no longer exists in supported versions.
History
Date User Action Args
2014-10-06 14:40:56georg.brandlsetstatus: open -> closed

nosy: + georg.brandl
messages: + msg228699

resolution: out of date
2014-06-10 23:07:01brian.curtinsetnosy: - brian.curtin
2014-06-10 22:57:37BreamoreBoysetnosy: + BreamoreBoy
messages: + msg220207
2011-10-05 00:50:24mhammondsetnosy: + mhammond
messages: + msg144933
2011-10-04 19:04:07brian.curtinsetmessages: + msg144923
2011-10-04 19:01:26ncoghlansetmessages: + msg144922
2011-10-04 18:56:18ncoghlansetnosy: + ncoghlan
messages: + msg144921
2011-10-04 18:36:48brian.curtincreate